Openhabian: Moving to new SD-Card: What has to be copied?

I think the GPIO binding is a version 1.x so make sure you have legacy addons enabled in PaperUI.

Have you stopped and restarted OH a few time? Took me three reboot before everything was all good.

Yes, include legacy 1.x Bindings in switched on.

But what is important for my functionality is to get zwave working!
I will do another reboot…

Make sure to Stop OH before each reboot.:wink:

I normally do a ‘sudo shutdown -r’ , isn’t that sufficient?


sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo systemctl start openhab2 or sudo reboot

I did that with clearing cache only 2x so far, but after the 3. it does not look better.
Zwave controller is online for a moment, some frames are sent/received and the it goes offline. Also the Yamha binding gets setup again and again and from MQTT I do not get any values, maybe while the system is occupied with the other stuff again and again.
GPIO install failure is also still in the loop :frowning:

This is my addons.config:


Stop OH and edit the addons.config file. Try changing the L"1" to L"2" in first line. After changing while OH is stopped clean the cache and reboot.

Not sure if this will fix the issue but worth a shot.:crossed_fingers:

Ok, did that.
Now at least the MQTT stuff is running again…
But still zwave is not working, an I see:

2019-12-28 17:52:57.197 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-gpio': Error restarting bundles:

	Exception in of bundle

Well, what has GPIO to do with Rest?

Stop OH again and edit the addons.config and remove GPIO from binding list. Also make sure its removed in addons.cfg and not installed in PaperUI. May need to check PaperUI before stopping OH.:wink:

After its removed from all locations, clean cache and reboot. Once OH is fully loaded and running you can reinstall gpio if you use it.

Looking at my addons.config, which does not have gpio binding installed, I see a few other differences. I have L"35" and a B in front of “true”. I will upload a pic and you can play with the file and see what happens.
Screenshot at 2019-12-28 11-14-22

I removed the GPIO as you described. Looks like the system is now running better. I don’t get the zwave binding online/offline, from the logs it looks ok, but the switches are still not reacting.

One thing is maybe suspect directly at system start:

==> /var/log/openhab2/openhab.log <==

2019-12-28 18:50:31.728 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.broadlink-2.2.0-BETA2.jar

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.broadlink [125]

  Unresolved requirement: Import-Package: org.eclipse.smarthome.config.core.status

    -> Export-Package: org.eclipse.smarthome.config.core.status; bundle-symbolic-name="org.openhab.core.config.core"; bundle-version="2.5.0"; version="2.5.0"; uses:=",org.eclipse.smarthome.core.i18n,org.eclipse.smarthome.core.util"

       org.openhab.core.config.core [139]

         Unresolved requirement: Import-Package: org.eclipse.smarthome.core.common.registry; version="[2.5.0,3.0.0)"

           -> Export-Package: org.eclipse.smarthome.core.common.registry; bundle-symbolic-name="org.openhab.core"; bundle-version="2.5.0"; version="2.5.0"; uses:=",,org.osgi.framework,org.slf4j"

              org.openhab.core [134]

                Unresolved requirement: Import-Package: tec.uom.lib.common.function; version="[1.0.0,2.0.0)"

                Unresolved requirement: Import-Package: org.osgi.service.component; version="[1.4.0,2.0.0)"

                  -> Export-Package: org.osgi.service.component; bundle-symbolic-name="org.apache.felix.scr"; bundle-version="2.1.16"; version="1.4.0"; uses:="org.osgi.framework"

                     org.apache.felix.scr [43]

                       Unresolved requirement: Import-Package: org.osgi.util.promise; version="[1.0.0,2.0.0)"

         Unresolved requirement: Import-Package: org.eclipse.smarthome.core.common; version="[2.5.0,3.0.0)"

           -> Export-Package: org.eclipse.smarthome.core.common; bundle-symbolic-name="org.openhab.core"; bundle-version="2.5.0"; version="2.5.0"

  Unresolved requirement: Import-Package: org.eclipse.smarthome.config.core

    -> Export-Package: org.eclipse.smarthome.config.core; bundle-symbolic-name="org.openhab.core.config.core"; bundle-version="2.5.0"; version="2.5.0"; uses:=",org.eclipse.smarthome.core.common.registry"

	at org.eclipse.osgi.container.Module.start( ~[org.eclipse.osgi-3.12.100.jar:?]

	at org.eclipse.osgi.internal.framework.EquinoxBundle.start( ~[org.eclipse.osgi-3.12.100.jar:?]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle( [bundleFile:3.6.4]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles( [bundleFile:3.6.4]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess( [bundleFile:3.6.4]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process( [bundleFile:3.6.4]

	at [bundleFile:3.6.4]

I will try the other options tomorrow, also reinstall GPIO.
Thank you very much so far for your help!

Edit: By the way: In Habmin the zwave devices are all “Node initialising: PING”

The warnings are about a jar file that lacks dependencies. Do you have anything in usr/share/openhab2/addons? If so, remove them for the upgrade and reinstall afterwards if needed. BTW you may no longer need a jar file addon in OH 2.5.:wink:

I will check tomorrow…
Looks like zwave is now working, it needed another half hour to get up to speed :blush:


Looks like after removing the jar files (if you have them in addons), stopping OH, cleaning the cache and restarting one more time all will be good.

Today I installed the GPIO and received again the installation error as above.
Clean cache and restart, et voila, GPIO works!

Now the last binding not working is the Broadlink. I still use the old org.openhab.binding.broadlink-2.2.0-BETA2.jar. Seems like this is no longer working with OH2.5 ??

2019-12-29 10:14:38.281 [ERROR] [nal.common.AbstractInvocationHandler] - An error occurred while calling method 'ThingHandler.handleCommand()' on 'org.openhab.binding.broadlink.handler.BroadlinkRemoteHandler@1d764df': bundleContext

java.lang.NoSuchFieldError: bundleContext

Ok, now I installed the newest Broadlink binding: org.openhab.binding.broadlink-2.5.0-SKUMPIC.jar
After another 3 restarts it looks now that everything is working.
Zwave items are still a bit laggy, it needs minutes until the actor switches, but maybe this improves after some time…
So in total I needed for the switch to OH2.5 abut 6h work, puh :upside_down:
Thanks to @H102 for your support :+1:

Glad to help.

Please click the sqaure box on soution post to mark topic as solved.


My old Raspi 3 died unfortunately. I have a Raspi 4 lying around which I don’t need currently, and I thought I could use this one instead.

Unfortunately, the SD doesn’t boot in the Raspi 4. So I don’t have any system that could boot that original SD. I can read it just fine from the Raspi 4, but only after I’ve booted from a freshly installed Raspbian.

So I can’t use the normal backup procedure to copy the installation (yes, I’ve negltected to create on in time - won’t happen again). But I have access to all files from the old SD.

What do I have to copy to get a running installation? Where’s the JSonDB located at? Anything else other than the stuff from /etc/openhab2?