Openhabian not showing up in network computers and devices

I am a noob and don’t have a whole lot experience with using the terminal on Openhabian. I installed openhabian (openhab2) on RPI 3. I was able to see the Openhabian on my windows pc after install. I set up wifi under openhabian-config. Install and configured HomeKit binding , finally got it going. While I was installing the HomeKit and wifi I had the window open for Openhabian on my pc. It took a few days to get HomeKit to work. I then closed the window for Openhabian. I few minutes later I tried to open it back up but it wasn’t on my network. I don’t know what I changed to make it not show up. I pulled up my router and looked under dhcp and there it is. I can also open Paper ui and I can see everything that I’ve added to Openhabian. So I know it’s on the network. It’s almost like Samba isn’t working. I was wondering if anyone else has had this problem?
Here is a picture of where it should be. Control panel-
Network and internet- view network computers and devices.

What happens when you type \\<name of openHABian machine> or \\<ip of openHABian machine>?

Even with samba running I’ve found Windows to inconsistently show the machines in network neighborhood.

Where do I need to type it in at? Browser?

Into Windows Explorer in the address bar. In the screen shot the part that says “Network”

This is what showed up.

This site can’t be reached refused to connect.
Checking the connection
Checking the proxy and the firewall

This seems to be the output of your Internet Explorer (IE) not your Windows Explorer (Filemanager).

Yes it is. When I typed the ip address into the windows explorer it pulled up Internet explorer window.

The \\ part must be used before the IP.

For example


1 Like

Ok, I need to pay attention more. I still have alot to learn. It did pull up the openhabian. Awesome thanks. It’s even showing up under computers and devices, now. I have another problem now. I can’t seem to add folders to the openhabian. It says " You need permission to perform this action?

Check the file permissions on your Linux folders and make sure that whatever user samba is configured with has write premissions. Or make sure to connect to the samba share using a user that has write permissions on those folders.

How do I check the file permissions on the folders? I tried to configure the smb.conf file for samba using putty but still hasn’t changed anything. I believe i used the user Openhabian when I first used samba. It doesn’t ask me for a username and password anymore when I click on Openhabian through my windows pc.

I don’t use samba much so will be of limited help. You can check the permissions on the folders using ls -l which will give you the owner, group, and permissions on the files and folders.

Heyho! First I have to satisfy one of my obsessions, answering questions with documentation links :smiley: Most of the time the answer to your question is one click away.

Regarding permissions: I’ve recently talked to another user about the same thing and I’ll look into permissions via samba later today. The current configuration is “read access to the important places, write access only where needed”, however as this confuses more users than it actually helps, I’ll do some opening up here…

Without going into detail now, if you really need to write where you do not have write access to right now, it might be the cleanest solution to copy the file to a place where you have write access, then move them from your linux console (SSH). There you’ll have the full control with sudo, chown and chmod (Read more here:

I’l check it out thanks

thomdietrich, I did copy the files to a writable directory. Etc/openhab2 using drag and drop on my pc with samba. Im trying to get the ( , org.openhab.binding.gpio-1.9.0-SNAPSHOT.jar ) files into the sys/class/gpio directory. I’ll paste a link to the post where I found this, when I find it. I’m doing all of this to try and get the gpio binding to work on Rpi3 with Openhabian.

I believe these files need to go into /usr/share/openhab2/addons

If that is the case, you’ll simply need to type:

sudo mv   /etc/openhab2/org.openhab.*   /usr/share/openhab2/addons/

et voilà

I’ve btw implemented the changes to Samba and access permissions (not merged yet):

Tried to move the file got this.
[13:11:08] openhabian@openHABianPi:/etc/openhab2$ sudo mv org.openhab.binding.gpio-1.9.0-snapshot.jar /usr/share/openhab2/addons
mv: cannot stat ‘org.openhab.binding.gpio-1.9.0-snapshot.jar’: No such file or directory
How do I make the changes on on the link you sent. Do I have to go to each file (, sbm.conf ) and make the changes or will they eventually be included in a future update?

SNAPSHOT or snapshot?? use the TAB key to type the commands

As @Windrad said, you’ve misspelled the name of the file, just as “No such file or directory” implies. Why didn’t you use the wildcard version I’ve given above? :confused:

I’ve merged the changes from the linked PR yesterday evening. Please execute in this order:

  • sudo openhabian-config
    • Update (get the latest openhabian-config version, including the PR changes)
    • Upgrade (upgrade all packages on your system, not needed but good practice)
    • Basic Setup (includes the new permissions settings and the consolidated share under /srv/)
    • Samba (will activate the new share)
    • frontail (while you are at it. The “openHAB Log Viewer” will be useful during rule building, after setup connect to http://ip:9001)

Connect via Samba to the new combined share “openHAB-share”. Copy the binding jar file into the addons folder.

Thomdietrich I thought the command you wrote was just an abbreviation for the file name. Didn’t know It was actually a command I could use. Thats why I didn’t use it. I still have alot to learn. Also didn’t know that caps mattered when typing a file name either. thanks