Openhabian - OH2.4 to latest milestone build - Failed Installing snmp1

Hi all,

I’m currently on Openhabian 2.4.0 on a rasp pi and it’s been absolutely rock solid since I installed it.

I’m in two minds about upgrading, I get that I’m missing out on some of the newer stuff and I’m sure 2.5 is as good as 2.4 if not better but I’m also thinking that if it ain’t broke don’t fix it…

So, anyone else gone done the install, anyone not looked back / regret it?

There are no current Milestone builds. Stable 2.5.4 just got released and any remaining 2.5.x releases will be addon changes only. There are 2.5.5 snapshots.

3.0 development has started but I do not think it is even usable yet.
There are a multitude of changes between 2.4 and any 2,5 version. It would be good to review the 2.5 Release Notes. You will likely want to update sometime. When is a choice only you can make.

1 Like

My recommend approach is to upgrade early and often or never upgrade anything ever.

If it’s not broken don’t fix it applies to the whole machine that OH is running on as and update to any library or other service on the machine can impact OH in some ways. So if you are afraid to upgrade OH you should not be upgrading anything else on that machine either. Just be sure to protect it as the number of known security problems it possesses will only grow over time.

So if you are up for upgrades, upgrade often. At a minimum keep up with the releases but I’d recommend keeping up with the milestones (we are in a weird place right now where instead of milestones we have point releases to 2.5 but the same applies). Why? because it’s far easier and far less work over all to deal with fewer and smaller changes than it is to deal with big changes. If you wait a year, or in your case two+ years before upgrading that’s two years worth of development that has gone on. Two years worth of potential breaking changes that you have to solve, new bugs added, deprecated bindings, and more. That means you’ll be scrambling and spending a weekend or more trying to chase down all the breaking changes that you need to fix in your config, some of which may build on each other or mask each other.

But, in my experience, upgrading once a month or two means that each time I upgrade there may be one or at most two breaking changes I have to deal with. Most of the time there is no breaking change at all. Do I same amount work over all? Probably. But I get to spread that work out in a 10 minute session here and a 30 minute session a couple months later and so on rather than needing to do all the work all at once over a weekend where the home automation may be offline or broken.

Usually, I will upgrade all my machines and docker images (it only takes one ansible command) once or twice a week. Does stuff break? Sometimes. But when it does it’s usually obvious what broke and why and easily fixable. If not, I have backups to roll back to or I can wipe the machine and rebuild with the old version it in a matter of 30 minutes or so in extreme circumstances (I’ve had to do this once in all the years I’ve run this way). The biggest impact I ever had was when I moved my RPis from jessie to buster and buster dropped ssmtp so I had to write an ansible playbook to install and configure msmtp instead (took about 30 minutes).

But that’s me. I’d rather spread the work out so it’s never a big deal than have it all build up to where if anything goes wrong it’s a huge deal to figure out why and solve it.


These are wise and true general wordings

Hummm, very wise words. I suppose that’s exactly my fear, getting left behind the curve and then having to spend too long catching up with it and fixing errors on the way.

I want to be up with the latest so I can contribute to the community more on testing etc. When I first started I was feeling my way and upgrading and breaking stuff was very daunting, it still is but less so now I know my way around more.

I’ve got some rudimentary backups but need to spend some time setting up proper incrementals etc and then I think I’ll jump up a few upgrades.

I feel the same, even if ‘small’ upgrades are not always easy as expected…

I can agree with that.

If you have no problems with your current version and never plan to use new features or bindings, I would stay with this version.

However, if you want to use the latest developments (features / bindings), even out of curiosity, you should carry out high-frequency updates.

However, the following must be done:

A backup before the update.

A backup before the update.

Yes, that is also partly stopping me at the moment, I really need to sort out a proper automatic / incremental backups first and then I might feel a little more comfortable with regular upgrades!

I went the whole hog and backed up the USB drive image of my 2.4 setup, restored to a new USB drive, and upgraded that. There were a few issues, but they were all documented on the forum.

Hi all,

Don’t know what all the fuss was about :wink: After a full backup I took the plunge, and I’m now on the latest version.

Pain free in the main…I just had to reconnect to my TV again no problem…

However, I’m getting the following in the logs, despite not having snmp binding installed? Any ideas???

[ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-snmp1, openhab-misc-restdocs'

resttocs moved to ui. Stop openHAB and edit the addons.config in the userdata tree (NOT addons.cfg in the config tree).

As stated in the Release Notes, there is now a v2 snmp binding. If you wish to use the v1 one, enable legacy bindings.

Failing to do both of these will cause all addons to reload every minute, trying to load the invalid ones/

Thanks, it’s confused me as I don’t use the snmp binding…must have installed it and then not used it or something…it’s not in the installed addons list so I’ll do what you say above and go from there…thanks for the help.

I also now realise why little and often upgrades might be better…going from 2.4 to 2.5 there are an awful lot of release notes to read through!

Sorry, new to this install / update OH process…

OH stopped, addons.config found…

I assume I just delete the snmp1 text from the ‘binding’ line?

1 Like

As you say you’re on openhabian, why don’t you use Amanda ?

Yes, that’s been something on my list for a while but as I’ve very little knowledge of Linux commands, (well, I haven’t used Linux for well over 15 years), it’s something that is a little daunting every time I start reading the docs.

I get the concept but the whole command line process to mount / get network share, (I want to use my Syno as the location), scares me a bit…I need some real focused, quiet time to get into it. Something that I unfortunately lack!

So, just to try and understand the process for ‘next time’…


Here’s my config, I get what I need to do, either delete snmp1 from the bindings line, or move restdocs from misc to ui…but can anyone tell me a little top level info behind the why please?

You did not read the information in the excellent release notes before upgrading. Your issues were addressed in the 2.5.0 release notes.


I did read the notes but as I was going from 2.4 there were a whole host of them, and it did get a bit confusing about what was broken but then fixed in the next release etc.

It’s another reason for the ‘pro’ column in upgrading regularly…

I will revisit the notes and work through them again.


Found what I was after…note to self, it was under

‘Breaking Changes that Require Manual Interaction after the Upgrade’

1 Like


One more question, if you will indulge me, that I can’t find in the docs / community…

I’ve changed the addons file so that:


But I still get the same error, to get rid of it I have to enable ‘legacy 1.x bindings’ / add legacy = true to the config file and then the error goes away, (obviously)…my question here is…

I don’t think I want to use legacy bindings, (unless someone can suggest otherwise - does it do any harm?), so I don’t want to have it enabled, but then the snmp1 binding throws the error…

How do I get rid of the snmp1 error, if I’ve already changed the addon config?

On the binding= line remove snmp1,.

1 Like