Openhabian on rp3

I am settind rp3 b with the openhabian files proposed in openhab site.
But my pi stucks ( have monitor connected ) on “login” stage and neither the keyboard runs nor the ssh connects using the proposed “openhabian” password.
Can somebody help me?

Are you using the 32bit or 64bit version of openHABian? 64bit is still beta, so be aware of that.

does that mean that the local attached keyboard is not working at all? Or do you just have problems with the login? Which user/password are you using?

Hi friends,
Yes i am using 32 bit version.
The keyboard y have is a blue tooth one as well as the mouse. It might be one of the resasons. Will have to try wired ones.
Besides the GUI when pointimg with the ip adress shows openhab running okey. But only when i call it with the ip adress not when i do it whith “openhabian:8080”

I don’t know how to set the raspberry with the last java version and then include openhabian. Should it be a reason?


If you are able to connect to your Pi by using a browser and the Pi’s IP address but not by using the hostname ( openhabian or the one that you used during installation ) then it is a matter of your router as it should do / does the name resolution.
On the computer that you use to connect via browser open a shell or command box and run: nslookup openhbian. Does that resolve the name ? You also can have a try and look into your routers interface and check if you can see the registered name there.

Please try with a wired keyboard

No, you should stick to the openHABian version. Makes it much easier and you can be sure that openHABian installs and updates all relevant components.

Since you were able to establish a SSH connection to your RasPI, which credentials have you tried? Sometimes people mix up the credentials for SSH with the credentials for the openHAB console.

Sascha + other fellows,
have solved the problem.
message was:

[user@hostname ~]$ ssh root@user
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
Please contact your system administrator.
Add correct host key in /home/hostname /.ssh/known_hosts to get rid of this message.
Offending RSA key in /var/lib/sss/pubconf/known_hosts:3
RSA host key for has changed and you have requested strict checking.
Host key verification failed.


Have found solution on :

Step 1

Open the Terminal app. The quickest way is to launch Spotlight and search for “terminal.” Or you can find it under “Utilities → Terminal.”

Mac terminal

Mac terminal

Step 2

Paste the following command.

nano ~/.ssh/known_hosts

Step 3

Remove the entry that is having the issue. If you aren’t sure which one to choose, look up your old and current IP address. Another option would be to remove all the entries.

Step 4

Type Ctrl + X (^X) to exit and select Y for yes when prompted if you want to save the modified buffer.

Terminal nano editor

Terminal nano editor

You should now be able to connect to your website and or server again.

Alternatively, you could delete your entire known_hosts file and let it repopulate. Enter the following command in the terminal.

rm .ssh/known_hosts
1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.