Openhabian: Problems with USB Hub

Tags: #<Tag:0x00007f616f230f78> #<Tag:0x00007f616f230eb0>

Since the latest kernel update in my RPI 3 running Openhabian 1.4 I’m getting a lot of problems with my USB Hub on the Raspberry. Devices connected to the hub often don’t work at all and the kernel log is spamed full by error messages. I found this issue on GitHub regarding the problem on the Raspberry. It seams that many people have this problem, but there is no solution so far.

Does anyone have the same issues with Openhabian? And does somebody know a way to solve this problem?

If it is a kernel problem then openHABian will have the same problems. openHABian is just Raspbian configured in a specific way.

USB hubs are known to cause hang ups even on windows. My friend had a lot of issues, he had like 5-10 hard drives. Ideally USB is supposed to be a bus running smooth. May be a kernel issue or hardware issue (either in sound card or hub or rasppi board itself). Later is difficult to fix. I am afraid you may have to buy yet another rasppi.

The raspberry pi don’t provide a lot of power through the USB port and it may be that your devices are drawing more than the pi can supply sometimes. Unless of course it’s a powered USB hub.

I use a powered USB hub on my Rpi 3B, and have no problems… Well except my RS485 (modbus binding) has started to get timeouts once in a while. It didn´t happen before. But my SSD and Z-wave dongle works just fine.

I’am using a powered usb hub. And I’m pretty sure that the kernel updated caused my problems because the whole system worked perfectly for almost two years with this usb hub. But shortly after the kernel update I noticed those problems. Then the log gets spammed full with those dwc_otg_handle_mode_mismatch_intr errors. Does anyone have the same errors in the log using an usb hub and the latest 4.14 kernel?

Then you need to follow up on that github bug. I see it is currently marked waiting from input from originator. Maybe maintainers are requesting additional data to locate the source of issue.

I’ve just got a hint on GitHub that the problem should not appear on Multi TT usb hub’s. Those are really rare, but I found an “Elektron Overhub” in a music store near me and ordered it. I will post here if this solves the problem with this error.

I’ve now received my Elektron Overhub and it acutally improoved the situation a lot. I’m now only getting a few of those error messages on startup. Also the ZWave delays are back to normal. I will continue to test this hub, but I think it solves the problem.

1 Like

Thanks for update. Let us know if major issues, so that we stay away from hubs.

I have an update regarding this problem. The usb hub did not solve the problem completly. After some days the errors occured again. But the problem is now solved in the kernel since yesterday. (See issue on GitHub)

The problem is solved with kernel version 4.14.71-v7+. At the moment this kernel can only be installed with rpi-update, but it will be installable via apt-get update soon.

2 Likes

Do you have a link for the usb hub, i want to power on external my ssd for the raspberry

You can take any usb hub for this. The problem was solved in the kernel of the Raspberry Pi. There should be no need for an expensive usb hub anymore.

And there is no backpower problem?

The problems I tried to solve with the Elektron Hub were not power but timing related. For power you just need a hub with a good power supply.