Openhabian Raspberry PI isntallation

Hello community. I have a question about Openhabian isntallation on Raspberry PI. I follow official instruction:

I download image file and do these steps :
Setup:

After this I wait 1 hour and try connect to Raspberry PI: type in browser window RaspberryIP:8080, and I can’t connect. Then I connect to Raspberry via Putty and see then next text:

dpkg-query: no packages found matching openhab2.
sed: can’t read /var/lib/openhab2/etc/version.properties : No such file or directory.

How can I solve this problem ? (I use 16GB SD card)

You can try sudo apt update then reboot. See if you have errors showing about an unreachable repository.

See if it fails again. It could be and issue with your dns server. There is a logfile firstboot.log I believe. It may give more details on the failure.

I had an error today on the openhab repository, not sure why but it worked a couple tries later. Maybe you experienced the same issue. If it does not work after a reboot, I would try re-make the sd card. If that does not work post your results with the first boot log and the team here should be able to offer suggestions.

I did all steps again (since SD card formatting). And now it works.

3 Likes

Great!

1 Like

Here we are…
My 1st question here is, what is the difference between the newest raspberry pi OS and the one suggested by OpenHAB since they appear to be base on buster but I have a filling this is not entirely accurate.

Thanks

It’s still based on the 1yr old Raspbian version, but effectively upgrades everything so in the end they’re equivalent.

Hello, I am using the Rasberrypi 3 B plus model with [v1.6-alpha] on my 16gb microSD. I am also facing the same problem as you did. I did forma my SD card and tried severarl times, but it doesnt work. The website is still not reachable. Please help me out

Do you have antivirus installed on your PC ? Do all these operations again with antivirus switched offf. If this will not help, try do it on other PC with other card reader.

Thanks for the reply Sherman, I could solve that issue, and now I im facing one more problem and ive made a post on it. Please check the link and try if you can help me.


Thanks again.