openHABian + RPi 3 = hangs

Now it is time to get more serious with openHAB, so I purchased a Raspberry Pi 3 to run it.

Due to my super basic Linux skills, I decided to use openHABian v1.4 (openhabianpi-raspbian-201712171718-git30faec3-crccc053823.img.xz) to drive the installation for me. Etcher was unable to find my card reader for some reason, so I used Rufus to burn openHABian into a 32 GB SD card.

RPi 3 is connected to a 5.1V / 2.5A power supply, and it is also attached to a monitor via HDMI. No other devices are connected to it. I can see startup process starting on the monitor, and then it gets stuck after displaying the following 2 lines:

[ 2.124914] smsc95xx 1-1.1:1.0 eth0: register ‘smsc95xx’ at usb-3f980000.usb-1.1, smsc95xx USB 2.0 Ethernet, …
[ 132.342723] random: crng init done

You can see there is a long wait between them, and after some 10 minutes the screen gets completely black. The lights are still on, but there is no visible progress whatsoever.

I see that the MAC address for this smsc95xx interface never shows up in my router and I see no device that could possibly match the Pi listed there. After failing with an Ethernet cable, I tried configuring Wi-Fi instead but the result is exactly the same.

Any ideas of what could be wrong here? Thanks in advance!

from what google provides:
the next step would be to mount the filesystems… so… it may be a bad SD Card or wrongly burned image.
I would try again from scratch :slight_smile:

If Etcher doesn’t work for you, try: Win32DiskImager

Before burning the image, i usually format the SD with another tool: https://www.sdcard.org/downloads/formatter_4/index.html
(Set “Format Size Adjustment” to ON in the Options menu)

http://docs.openhab.org/installation/openhabian.html

There is several of us that have installed the 1.4version successfully on the new RPi3 so i suspect this is a problem due to a corrupt image.
Without knowing much about how the first outputs you are reseiving i would assume this is much like the POST sequence a pc runs through before dealing with the software itself. In other word it initializes hardware on the RPi before reading anything from the sd card.
As Dim suggests i think this is a problem with the image.

I personally used 7zip to decompress the file before writing the image with the Win32DiskImager. Worked like a charm first time. Keep in mind that if you install the image (first boot) with ethernet cable connected you will need to stick with this option to have the possibility to access your OpenHab system with your mobile device. This is because of the UUID and secret that the Myopenhab service need for accessing your system safely.

1 Like

I have downloaded Win32DiskImager and used it to burn the image again - worked like a charm, thanks for the helpful feedback!

From what I can see on the logs, all seems OK so I will start playing with the configuration:

[17:24:39] openhabian@openHABianPi:~$ cat /boot/first-boot.log
2017-11-29_02:37:20_UTC [openHABian] Starting the openHABian initial setup.
2017-11-29_02:37:20_UTC [openHABian] Storing configuration... OK
2017-11-29_02:37:20_UTC [openHABian] Changing default username and password... OK
2017-11-29_02:37:21_UTC [openHABian] Setting up Ethernet connection... OK
2017-11-29_02:37:21_UTC [openHABian] Ensuring network connectivity... OK
2017-11-29_02:37:21_UTC [openHABian] Waiting for dpkg/apt to get ready... OK
2017-12-26_21:51:33_UTC [openHABian] Updating repositories and upgrading installed packages... OK
2017-12-26_21:53:44_UTC [openHABian] Installing git package... OK
2017-12-26_21:54:38_UTC [openHABian] Cloning myself... OK
2017-12-26_21:54:40_UTC [openHABian] Executing 'openhabian-setup.sh unattended'...
2017-12-26_21:54:40_UTC [openHABian] Checking for root privileges... OK
2017-12-26_21:54:40_UTC [openHABian] Loading configuration file '/etc/openhabian.conf'... OK
2017-12-26_21:54:40_UTC [openHABian] Setting timezone based on IP geolocation... OK (America/Toronto)
2017-12-26_16:57:02_EST [openHABian] Setting locale based on openhabian.conf... OK
2017-12-26_16:57:31_EST [openHABian] Setting hostname of the base system... OK
2017-12-26_16:57:31_EST [openHABian] Setting the GPU memory split down to 16MB for headless system... OK
2017-12-26_16:57:31_EST [openHABian] Enabling Audio output... OK
2017-12-26_16:57:31_EST [openHABian] Installing basic can't-be-wrong packages (screen, vim, ...)... OK
2017-12-26_16:59:24_EST [openHABian] Installing additional needed packages... OK
2017-12-26_17:00:17_EST [openHABian] Installing additional bluetooth packages... OK
2017-12-26_17:01:03_EST [openHABian] Adding slightly tuned bash config files to system... OK
2017-12-26_17:01:03_EST [openHABian] Adding slightly tuned vim config file to system... OK
2017-12-26_17:01:03_EST [openHABian] Downloading and setting up FireMotD... OK
2017-12-26_17:02:53_EST [openHABian] Installing Zulu Embedded OpenJDK... OK
2017-12-26_17:05:34_EST [openHABian] Installing or upgrading to latest openHAB release (stable)... OK
2017-12-26_17:06:49_EST [openHABian] Adding an openHAB dashboard tile for 'openhabiandocs'... OK
2017-12-26_17:06:49_EST [openHABian] Adding openHAB syntax to vim editor... OK
2017-12-26_17:06:50_EST [openHABian] Adding openHAB syntax to nano editor... OK
2017-12-26_17:06:50_EST [openHABian] Adding openHAB scheme to mulitail... OK
2017-12-26_17:06:50_EST [openHABian] Preparing openHAB folder mounts under /srv/... OK
2017-12-26_17:06:50_EST [openHABian] Applying file permissions recommendations... OK
2017-12-26_17:06:52_EST [openHABian] Applying miscellaneous system settings... OK
2017-12-26_17:06:52_EST [openHABian] Setting up Samba network shares... OK
2017-12-26_17:08:40_EST [openHABian] Installing Node.js (prerequisite for other packages)... OK
2017-12-26_17:09:58_EST [openHABian] Installing the openHAB Log Viewer (frontail)... OK
2017-12-26_17:10:27_EST [openHABian] Adding an openHAB dashboard tile for 'frontail'... OK
2017-12-26_17:10:27_EST [openHABian] Execution of 'openhabian-setup.sh unattended' completed.
2017-12-26_17:10:27_EST [openHABian] Waiting for openHAB to become ready... OK
2017-12-26_17:11:07_EST [openHABian] Visit the openHAB dashboard now: http://openHABianPi:8080
2017-12-26_17:11:07_EST [openHABian] To gain access to a console, simply reconnect.
2017-12-26_17:11:07_EST [openHABian] First time setup successfully finished.
[17:30:28] openhabian@openHABianPi:~$
1 Like