Openhabian unattended install for OH3 or stable doesn't result in OH3

I’m trying to get a clean current openhabian running with openHAB 3.4.4 before upgrading to openHAB4M4. This is on a Pi4B.

I downloaded the then latest openhabian image openhabian-pi-raspios32-202306251506-gitb1e94d8-crc6a90b686.img. I then wrote the image to the SD card using the Raspberry Pi imager (custom image - not sure if the openhabian image that the imager offers is the latest).

I edited the openhabian.conf file to, among other things, specify that I wanted OH3, i.e. clonebranch=openhab3.

What I got was openHAB4M4. It didn’t recognize the file I had provided, perhaps because it was an OH3 backup and it is looking for OH4. So basically I got a clean OH4M4 set up. I understand that you don’t get the important benefit of the conversion script if you just restore a OH3 backup to an OH4 system.

I next tried changing to clonebranch=stable. That got me openhab2.5.12-1.

Seems like I’m missing something, but can’t figure out what I need to set clonebranch to in order to get OH3.

(I tried adding the complete first-boot.log files, but that made the post too big, but I have them and can provide info from them if that will help).

I’m trying a downgrade of the OH4 install to OH3.4.4 using openhabian-config.

Did you try to attach the log as a file instead of copying its content as inline text ?

As far as I understand the docs clonebranch=openhab3 should have been correct.
What else things did you edit ?

It’s unfortunate timing. I forward-changed openHABian to install OH4 milestone some days ago in preparation of the release to come. Install OH4 then use the interactive menu to switch to release to get back to OH.

It turns out that when I named it in windows explorer, windows helpfully added another .zip, so the file was actual named It is actually good that it was recognized (I think) because it might have missed the upgrade script.

At any rate, downgrading using openhabian-config menu 41 release worked and I then restored the the openhab 3.4.4 system back up. I have a few things to do (like get mosquitto and Somecomfort-homie running) before I try to upgrade to openHAB4.

I don’t know if the issues with Marketplace bindings in the upgrade have been resolved, but to be safe, I plan to delete the ones I am using (smarthome/j amazonechocontrol and tuya), do the upgrade and then install them anew from the Marketplace.

What about MarketPlace Rule Templates? I use the Debouce template. Do I need to delete it and install a new one after upgrading?

Should this be fixed by now? I also got openhab 4.0.1 instead OH3.

Case matters. Docs were wrong there, will be corrected.

Retry and use debugmode=maximum eventually post /boot/first-boot.log if it doesn’t work.

1 Like

Thanks for the quick reply! That solved the issue.

Hi mstormi,
I think there is one additional location where a similar change is required as well: :

To have it install openHAB 3, set clonebranch=openHAB in openhabian.conf.