Openhabian update destroys deconz config

many thanks to mstormi for steadily improving the update process of openhabian-config.
Unfortunately, in my config there is a hickup.
Due to a conflict with the sonos binding I need to alter the port of the deconz binding and deactivate upnp in /lib/systemd/system/deconz.service and /lib/systemd/system/deconz-gui.service after each major update by manually editing a specific line:

ExecStart=/usr/bin/deCONZ -platform minimal --http-port=8007 –upnp=0

Would it be possible to keep these line between updates?


openHABian does not change these files. You would need to talk to the maintainers of the deconz service package. You might be able to use an override file like we do for the openhab2 service to get around that.

ok, thank you Markus!

@mstormi I asked the deconz community.and got a reply:

@openschwall I’ve already requested to get in contact with their maintainer: openhab/openhab-addons#8379

Could you please ask him to join our discord? This isn’t something to be discussed here.

As I do not know the maintainer on the side of openhab I am now out of options.

In the linked discussion Christoph replied:

I am not sure if the initial contributor (@davidgraeff) of the deCONZ binding is still around. In the past weeks @J-N-K and myself were working beside others on improvements or bugfixes.

@openschawll have a look to

and check if that works the override.conf is a linux ‘feature’ and should work.

Detailed steps are explained in the answer to

@Wolfgang_S I will give it a try . Thanks for pointing to this.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.