Openhabian - Update to Version 4 of OpenHab missing requirement runtime

  • Platform information:
    • Hardware: Rasperry Pi 4 Model B Rev 1.4

Just updated vie OpenHabian to 4.0 but now I have a lot of errors in the log file.
There are missing main components it seems and the system does not work of course.
Can someone please help and let me know how I can solve this?

2023-08-14 09:40:27.626 [ERROR] [ternal.service.BootFeaturesInstaller] - Error installing boot features

org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-runtime-ui; type=karaf.feature; version="[4.0.1,4.0.1]"; filter:="(&(osgi.identity=openhab-runtime-ui)(type=karaf.feature)(version>=4.0.1)(version<=4.0.1))" [caused by: Unable to resolve openhab-runtime-ui/4.0.1: missing requirement [openhab-runtime-ui/4.0.1] osgi.identity; osgi.identity=openhab-runtime-base; type=karaf.feature [caused by: Unable to resolve openhab-runtime-base/4.0.1: missing requirement [openhab-runtime-base/4.0.1] osgi.identity; osgi.identity=openhab-core-base; type=karaf.feature [caused by: Unable to resolve openhab-core-base/4.0.1: missing requirement [openhab-core-base/4.0.1] osgi.identity; osgi.identity=org.openhab.core.config.core; type=osgi.bundle; version="[4.0.1,4.0.1]"; resolution:=mandatory [caused by: Unable to resolve org.openhab.core.config.core/4.0.1: missing requirement [org.openhab.core.config.core/4.0.1] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.openhab.core.common.registry)(version>=4.0.0)(!(version>=5.0.0)))" [caused by: Unable to resolve org.openhab.core/4.0.1: missing requirement [org.openhab.core/4.0.1] osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=17))"]]]]]

at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1341) ~[org.eclipse.osgi-3.18.0.jar:?]

at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:433) ~[org.eclipse.osgi-3.18.0.jar:?]

at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:420) ~[org.eclipse.osgi-3.18.0.jar:?]

at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:374) ~[org.eclipse.osgi-3.18.0.jar:?]

at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:256) ~[?:?]

at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:399) ~[?:?]

at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1069) ~[?:?]

at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:1004) ~[?:?]

at java.util.concurrent.FutureTask.run(FutureTask.java:264) ~[?:?]

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) ~[?:?]

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) ~[?:?]

at java.lang.Thread.run(Thread.java:829) ~[?:?]

Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve openhab-runtime-ui/4.0.1: missing requirement [openhab-runtime-ui/4.0.1] osgi.identity; osgi.identity=openhab-runtime-base; type=karaf.feature [caused by: Unable to resolve openhab-runtime-base/4.0.1: missing requirement [openhab-runtime-base/4.0.1] osgi.identity; osgi.identity=openhab-core-base; type=karaf.feature [caused by: Unable to resolve openhab-core-base/4.0.1: missing requirement [openhab-core-base/4.0.1] osgi.identity; osgi.identity=org.openhab.core.config.core; type=osgi.bundle; version="[4.0.1,4.0.1]"; resolution:=mandatory [caused by: Unable to resolve org.openhab.core.config.core/4.0.1: missing requirement [org.openhab.core.config.core/4.0.1] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.openhab.core.common.registry)(version>=4.0.0)(!(version>=5.0.0)))" [caused by: Unable to resolve org.openhab.core/4.0.1: missing requirement [org.openhab.core/4.0.1] osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=17))"]]]]

at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1341) ~[org.eclipse.osgi-3.18.0.jar:?]

... 12 more

Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve openhab-runtime-base/4.0.1: missing requirement [openhab-runtime-base/4.0.1] osgi.identity; osgi.identity=openhab-core-base; type=karaf.feature [caused by: Unable to resolve openhab-core-base/4.0.1: missing requirement [openhab-core-base/4.0.1] osgi.identity; osgi.identity=org.openhab.core.config.core; type=osgi.bundle; version="[4.0.1,4.0.1]"; resolution:=mandatory [caused by: Unable to resolve org.openhab.core.config.core/4.0.1: missing requirement [org.openhab.core.config.core/4.0.1] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.openhab.core.common.registry)(version>=4.0.0)(!(version>=5.0.0)))" [caused by: Unable to resolve org.openhab.core/4.0.1: missing requirement [org.openhab.core/4.0.1] osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=17))"]]]

at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1341) ~[org.eclipse.osgi-3.18.0.jar:?]

at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1341) ~[org.eclipse.osgi-3.18.0.jar:?]

... 12 more

Please read the prerequisits. Latest openHABian requires debian 11 (bullseye) and openHAB 4 requires Java 17.

Sorry. I need to read the upgrade notices better :frowning:

3 Likes

You ain’t the first but one of the first to admit - thanks.

3 Likes