OpenHabian v1.6.3 Frozen Updating OH 3.x to latest SNAPSHOT

Continuing the discussion from openHABian 1.6 released:

@mstormi I foolishly upgraded OpenHabian to 1.6.3 and then tried to upgrade OpenHAB itself to the latest SNAPHOT – but it has frozen (last log message below) frozen for 35 minutes…

2021-01-28_17:55:33_GMT [openHABian] Installing selected openHAB3 version...

Neither was there a discussion nor should you ping people. And I don’t understand what you want to tell either.

No. Because that announcement thread is closed. Otherwise I would have discussed in that thread.

And that is why I pinged you. Since otherwise you would not have known that the announcement thread is closed.

I am telling you that the 1.6.3 FAILS to install the latest SNAPSHOT.

And I am asking you (kindly), and others who may see this thread, if there is a solution to that.

PS I can ping the server, and see its samba file shares (so it is not dead). However I can see many files in all folders like the following…


I know it is closed. It has been closed from the beginning for users. That’s the nature of an announcement thread.

And this is not ok. Most people dislike being pinged and so do I, and that’s why it’s in the forum communication rules not to do it.

I don’t know. That is just a symptom so noone can tell if you don’t give all the details. See debug guide.

1 Like

Thanks for the helpful tip. Here is the debug log.

openhabian-config debug log menu item 41 snapshot fais.txt (42.6 KB)

But perhaps the log doesn’t give the details you need, so here are some screenshots showing how I got to this failure.

Menu Item 40 | 41 | SNAPSHOT

Note that the first time I tried this command, the installation froze at

2021-01-28_17:55:33_GMT [openHABian] Installing selected openHAB3 version...

And after setting debugmode=maximum, and rebooting the server, the second time I tried the upgrade command resulted in error dialog below, and the log file previously submitted…


Then what about reading into it ? You shouldn’t expect me to debug that for you.
So just for your start this is why it fails, it and even tells you what you need to do.

$ apt-get install --allow-downgrades --yes --option Dpkg::Options::=--force-confnew openhab=3.1.0~S2169-1 openhab-addons=3.1.0~S2169-1
+ apt-get install --allow-downgrades --yes --option Dpkg::Options::=--force-confnew openhab=3.1.0~S2169-1 openhab-addons=3.1.0~S2169-1
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
+ return 100
+ echo FAILED
+ return 1

Dear Markus, do you always have to be so unpleasant? But thankyou anyway for your post. I had in fact already read the log, and I had in fact already seen and applied the command sudo dpkg --configure -a before you posted. But it did not actually solve the problem. And it certainly does not explain why your openhabian-config software failed several times in the process. Perhaps there could be some bug in your code it that you might want to look at?

Nevertheless I tried a few more times, and got similar openhabian-config error dialogs. I am pleased to advise that (sorry to say but not really any thanks to you or your polite manner), I was able to solve it by downgrading to OH v3.0.1 and then upgrading again to OH v3.1.x-SNAPSHOT

And you expected him to be a mind reader knowing that?
How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

BTW if you want to file an issue about something being broken, that is the purpose of GitHub Issues and how things get fixed.

File it here.

Bruce. No. I read the log after I posted it, and then he posted that I should read the log. So he was not reading my mind either. The two messages simply crossed. I just expect that people try to be more polite.

You did not tell us you ACTED onit Many people post the log asking what is wrong when the log clearly states the issue.

Yep. I acted on it. And I said so. The messages just crossed.

Well so do I, so in the first place I expect people that want help to at least provide their share which is essentially to follow the guide Bruce posted and understand that they expect others to spend theirs time for them, for free. Bold letters isn’t polite either btw.
Then when I need to notice they didn’t do their share I’m not amused at all. You did not do a number of things you should have done upfront such as not to ping me, to read the docs (which would have told you there’s the debug guide), the guide itself, and finally you say messages crossed but frankly I still do not see where you have indicated you read the log let alone mention you tried those commands. But you still expect me to ask even more politely then call me unpleasant ?
No comment other than good luck on your next issue.

Can I ask why you want to run the Snapshot version? It seems you have little knowledge of OpenHabian and being on the cutting edge is just going to make things harder for yourself.

I’d also like to say that everyone involved in OpenHab is a volunteer and hence when asking a question you should do so with some level of respect - the way you came across is as though you are entitled to responses and support which will irk some people.

1 Like

Dear All, I apologise to anyone who thinks I have been impolite on this thread.