Openhabian Wifi on RPi2

Does anyone know how to set up Wifi on RPi2 under openhabian? My current RPi2 wifi works fine under Jessie lite, but when I install openhabian, the set up doesn’t work. I have searched, but have not found the answer.


I am also having problems with wifi with Openhabian on a Pi2. I’ve looked at so many different articles and am now thoroughly out of my depth.

I have a working openhab 1.x installation using a wifi connection and am now creating a clean OH2 installation by swapping the SD card. The USB wifi adapter worked right out of the box when I first installed OpenHAB, so…

Is there something missing from the Openhabian installation that is required to get wifi working? For example, I keep finding references to the wpa_supplicant.conf file, which doesn’t seem to exist on the Openhabian installation?


1 Like

I don’t have an answer but going to add my 2p worth to see if it moves us on as I have the same issue!
I originally setup OpenHabian on Ethernet and am now trying to switch to WiFi.

I’ve been into the Openhabian setup
sudo openhabian-config
And added my WiFi details (system settings, Wifi)

It looks like it is working
ifconfig wlan0
now shows my ethernet and
ifconfig wlan1
shows my wifi (connected with an IP address)

I think the issue may be with the hostname? When I try to connect via the IP address both connect. If I unplug the ethernet then I can access OpenHab with the IP address but not the hostname (http://openhabianpi:8080/) which I’d like to keep.

There are instructions for a wifi only setup on the OpenHabian install page but I really don’t want to have to go back to square 1!

I’ve got the same issue. Did anyone find the answer? Have set conf file as per instructions and can see the adapter under ifconfig but it won’t connect.

SOLVED. :slight_smile: Typo in wpa_supplicant.conf …oops