Openhabian Zwave controller is offline (Aeon Labs gen5, raspberry2 )


I am stuck overall almost a week by zwave binding in OH2. Using openhabianpi-ua-netinst-20170317-gitbd31755f-crc88a5ae46.img.
I have tried at least 10 different approaches but controller is still offline in openhab.


  • disabling in openhabian-config options 1 (disable serial console) and 3(add common serial ports to OH JVM)
  • editing setenv file adding JAVA OPTS
  • changing access rights to /dev/ttyAMA0
  • openhab user is added in dialout even tty
  • serial-getty@ttyAMA0.service stopped or masked to /dev/null
  • enabled uart
  • installing liblockdev1-dev library
    and maybe more…

When adding in HABMIN or PAPER UI i acan add zwave binding, i can set controller serial port to /dev/ttyAMA0 where it really is (from sytem log ) because it is properly loaded to system and openhab loads and initializes controller but next it just turns it offline and timeouts every request like in most of cases i saw.

Please tell me what to do, i am not totally amateur but not good in linux.

P.S.: My Zwave stick is properly working on my PC where I have Domoticz installed and it works without problems. But i want to switch it to rpi2.

Thank you for any help


Are you seeing errors in your log files? Is the controller ever shown as online?

Also, see if you are running any other bindings that use the Serial port. I’ve ran into conflicts there in the past as well.

Thank you for tips so :
dmesg is showing

[419952.705981] usb 1-1.4: new full-speed USB device number 6 using dwc_otg
[419952.809328] usb 1-1.4: New USB device found, idVendor=0658, idProduct=0200
[419952.809485] usb 1-1.4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[419952.811295] cdc_acm 1-1.4:1.0: ttyACM0: USB ACM device


binding is only zwave(COM) milight(UDP) and ubiquiti (TCP)

is there anything that can block my controller or how could I find if it is online in linux not in openhab??

I am soooo stupid but i bet that I tried to configure ttyAMA annd ttyACM and ttyS0 and others… but now i see ACM and when I set up ttyACM0 and restarted openhab it started working. I don’t know if switching USB could change it but I don’t think so.

Thanks for help solved for now.