OpenHABian2.4 Ip-configuration & KNXd

Good evening,

I’m from Germany and new here in the forum. I used the software SmarthomeNG with KNXd on a Raspberry PI.

I’ve been using OpenHAB for a while, but I can not handle some settings. Maybe I can be helped here.

I use the finished image for the Raspberry PI 3 B+ from OpenHabian2.4. The basis is a Raspbian stretch. The Raspberry is connected via wifi with my Fritzbox. A Weinzerl 731 KNX-IP gateway is connected to the Ethernet port. Unfortunately, static IP assignment via the dhcpcd.conf file does not work.
After each reboot i must enter the ip for eth0 with the command “sudo ifconfig eth0 192.168 …”.

Then I would like to program from my laptop with the ETS5 continue the KNX. Is it possible to forward the IP interface via WLAN?
Currently I have installed KNXd to use this as a programming interface. This works but is KNXd necessary too?

Then I have another problem with the HUE emulation. openHABian is running on port 8080. I have forwarded about iptable requests from port 80 to port 8080, since Alexa probably only looking for port 80.
I do not see all the items with [ “Lighting” ] tags in Alexa via the HUE emulation, and they often “do not respond” … But everything works with the MyOpenhab cloud.
Is there a trick in the HUE emulation that I did not find out?

Have a nice evening

greeting Michka.

translatetd via google-translator :stuck_out_tongue:

Hello vzorglub,

Thank you for your answer.

I gather from your short answer that it should work normally like any other Raspbian.
I know these settings and it have always worked with my previous system.
because this type of settings in dhcpcd.conf and/or interfaces.conf do not work I have
suppose that openHAB overwrites something here. Or something like that.
Maybe it’s the finished image.I will install OpenHAB on a Raspbian by myself if I have time.

regards Michka

OpenHABian is only raspbian with a bunch of scripts to automate the setup and some 3rd party utilities.


I played around a bit and came to a solution.
When I started the raspberry on a monitor, I saw an error in the DHCPcd during boot logging.
maybe I should have looked at the service earlier.

The one who created the finished image has entered too much in the etc/network/interfaces file
This turned off the DHCPcd service.

According to your link, in Raspbian “Stretch” needs only a link to Intrefaces.d in the interfaces file.
So the DHCPcd error was gone but the wlan could not connect.

Despite the fact that I am running a PRETTY_NAME = “Raspbian GNU / Linux 9 (stretch)”
I had to describe the file as it had been required under JESSIE.
The static IP assignment now works!

But I have no solution for the “forward” of my KNX-IP interface.
I tried an AP, a bridge and ip_forward with iptable. Unfortunately unsuccessful.

greetings, Michka