OpenTherm Gateway binding

Arjen,
thanks for your reply. You’re totally right. I found this in the otgw forum:
https://www.domoticaforum.eu/viewtopic.php?f=75&t=11959&start=0&hilit=circuits

Seems like it needs to be changed in the firmware :frowning:
Will report back, if I have found a way to change the FW.

BR
Frank

Well, unless you are, or you can find, an assembly programmer that is willing to put in the time to write a custom firmware… chances are quite slim you would get this to work with the OTGW.

If you really must control both setpoints, you may want to look at alternatives… such as using a different gateway, home made or commercially available devices.

Hi Arjen,

Thanks for this new version !
Version 0.9.0 works perfect for me (on OpenHab 2.4.0), I didn’t try 1.0.0

My sitemap example for the new fault indicator :

Text item=OpenThermGateway_OEMFaultCode label="FaultCode : " icon="error" labelcolor=["red"] valuecolor=["red"] visibility=[OpenThermGateway_FaultIndication==ON]

Thanks again !
Peter.

Hi Peter,

Great to hear it’s working!

Version 1.0.0 is almost identical to 0.9.0, I just wanted to increase to a production version number for the pull request.

Did you find a list somewhere that explains the OEM codes? Like 133 = no flame?

When I manually close off the gas, some OEM fault code is reported (not sure it’s 133), but I can’t seem to find a proper list of fault codes and their meaning for my Remeha Avanta boiler.

Hi Arjen,

I have an Elco Thision 9 gas boiler, with a Siemens LMU54​ controller.
When I manually cut off the gas, I get the fault code 133 : No flame during safety time​.
But unfortunately I get this fault also from time to time by an abnormal startup of the boiler …
This code is indicated on the display of the boiler and also correctly decoded with version 0.9.0 of your binding.

I found for my boiler a list in this manual on page 25.
But I think this list is vendor and boiler specific !

I found for your boiler on page 50 of this manual :
Error code E4 : More than 5 start attempts without any flame formation.​
This must be corresponding with my code 133 …

Do you find back this OEM fault code E4 in your binding ?
Or do you see this code in the original OpenTherm Monitor application ?

Kind regards and thanks for all your efforts and keep up the good work,
Peter.

Remeha has some mapping from the faultcode that is reported on opentherm (133) and the faultcode in the manual and also the display on the boiler itself (E4).

So… I did find this list of Exx codes… but that’s not what I get back on opentherm.

Well, it’s not that big of a deal… my boiler hardly ever goes into fault mode, and even if it does, the general fault indication is still activated on opentherm, so I just need to check the display and find the corresponding Exx code to find out whats wrong.

Hi Arjen,

I dont know how your binding is working for me, but respect for everything what you have done so far whit this binding for evereryone!

My question is, is it already possible to connect with usb? (The OTGW -> RPi with OpenHab)
It has been mentioned in earlier posts.

Chears!

Hi @Pompom,

The binding does not yet support USB connection, simply because so far I haven’t found anyone that uses it… so no need to work on it and also no way of testing it…

I would gladly add support for it, if you are willing to test it :wink:

Hello,

The testing would be a challenge. I am already happy that I managed to install openhab, my skills regard to openhab / rpi is not great. I just started with openhap and the Rpi.

I think the easiest way for both of us to is go for a NodeMCU so that I work via a TCP connection.

However if you create a support for USB connection I can give it a try, but if I dont get it,it’s a waste of your time if you made it especially for me. I wouldn’t want that.

Hi Arjen,

I’ve been using your binding for some time now, big thanks for your work.
I have just updated to 2.5.2 but your binding is not coming online. my paperui thing stays “uninitialized”.
The binding is not showing up in the console (bundle:list). it is like its not in the addons folder (which it is, tried with version 2.5.1 and 3.0.0). I have wipes cache and tmp dirs (openhab-cli clean-cache).
I’m on an openhabian system running on a pi4.
Starting openhab in full debug but nothing on opentherm showed up.

Do you have any ideas?

best regards,
Danny

Hi @derkens,

Somehow the binding is not picked up correctly by openHAB. That also happens to me from time to time… usually removing the binding completely, restarting openHAB and then adding it again to the addons folder solves the issue.

Also, see this post: OpenTherm Gateway binding

Let me know if this works for you.

Regards
Arjen

Hi Arjen,
Thanks or the tips, but that was not working.
Turns out I was downloading (or saving) corrupt files, seems
wget https://github.com/ArjenKorevaar/openhab2-openthermgateway-binary/blob/master/org.openhab.binding.openthermgateway-2.5.1-SNAPSHOT.jar
is not the right way of downloading the binding. :upside_down_face:
Downloaded another way and now all is well.

Danny

Glad you got it working… although wget should work just as well :thinking:

[edit]
Oh wait, that link just points to the Github web page for the specified file… but not the actual file itself. For this you would need to use the raw url which is also used by the Download button: https://github.com/ArjenKorevaar/openhab2-openthermgateway-binary/blob/master/org.openhab.binding.openthermgateway-2.5.1-SNAPSHOT.jar?raw=true

Or… the final url where that ‘raw’ url redirects to… which is: https://raw.githubusercontent.com/ArjenKorevaar/openhab2-openthermgateway-binary/master/org.openhab.binding.openthermgateway-2.5.1-SNAPSHOT.jar

Thanks for the links, next time I’ll remember to use the raw options. This time I downloaded the raw file on my laptop and scp’d it over.

I’m looking into adding support for serial (USB) connection, next to the existing IP socket connection.

Putting everything in one Thing would work, but kinda feels like a mashup since it would end up with only one configuration with values for both types of connection. Also, this one Thing would need to support serial connections (SerialPortManager) while based on the config this may not be used at all…

So, to support different types of connection to the same device… would using different Bridges for each type of connection be the way to set this up?

Hi,
I just installed the Opentherm binding and everything seems to be correctly installed.
I have a Remeha Tzerra Ace with e-twist thermostat, this thermostat has a wifi connection. Can I use this to connect to the binding or do I need a seperate opentherm - tcp interface for this?
When i use the IP of the e-twist the opentherm thing stays offline.
I am using 8000 as port.
Kind Regards,
Will van Gemert

Hi @Willem

This OpenTherm Gateway Binding is specifically developed for the OpenTherm Gateway device designed by Schelte Bron. This device is connected inbetween your boiler and thermostat and allows interaction with the OpenTherm data.

I am not familiar with the e-twist thermostat but from what I read on the internet it doesn’t have an open API. That would mean that it can’t be connected to directly with a binding like the TCP binding or an MQTT. However, since it uses the OpenTherm protocol, one option is that you add an OTGW to control the thermostat and boiler using openHAB.

Hi @Mephix
Thanks for the fast response, I will go for the gateway solution, Will follow the link provided to source the necessary components,
KInd regards Will

Hi @Willem

The OTGW can also be bought pre-assembled, for instance at Nodo-shop. In any case, make sure you include a wifi or ethernet module to connect the OTGW to your home network.

Please note that the OTGW will only provide features that are related to the opentherm protocol. Your thermostat and even your boiler may have additional features that can’t be controlled by the OTGW.

Hi everybody!

Thank u @Mephix this was what i needed.

I had a old version usb (serial) only and made it work unther linux by using a application as a bridge.
The application is “ser2net” its pretty default linux. Its configurable to open a TCP port and forward/connect it with a serial device.

Install with : apt-get install ser2net
edit: sudo nano /etc/ser2net.conf --> disable all default active lines with ‘#’
add: 7000:raw:0:/dev/ttyUSB0:9600 8DATABITS NONE 1STOPBIT remctl

Now port 7000 will be opened for device ttyUSB0 with 9600 8DATABITS NONE 1STOPBIT

Enable service with: systemctl enable ser2net

Start service with: systemctl start ser2net

check the status with systemctl status ser2net

If you disable the binding you can also connect to the device from your network.
(i used otmonitor.exe unther windows for that).

p.s.: when i bought the device it came with diagnostic firmware loaded so its wise to first check the device and its installation with the desktop version, its there where you can change the firmware.

1 Like