OpenWeatherMap - City not found

today i looked into my logfiles and i get an error message:

2016-09-15 08:27:25.568 [ERROR] [.w.i.p.AbstractWeatherProvider] - OPENWEATHERMAP[home-owm]: Can’t retreive weather data: Error: Not found city

OpenWeatherMap worked since few months without problems. Today i updatet all my bindings to 1.8.3. Formerly the bindings were 1.8.2.

I don´t know, how long this error is there, but it worked a few days ago.

Was there a change in configuration?

Looks like a server overload on OWM.
See answer from Ivan (Sep 15, 2015 03:51PM UTC) at this link:


How should i configure my location? Is xx,xx enough or should i enter more digits like xx,xxx or xx,xxxx?

It depends:
You need 5 decimal places for an accuracy of 1 meter.

By the way, configuration is done with a point, not a comma:


I configured my position with . and not with , that was only a mistake here in the thread.

My nearest weather station is about 20 km away, the next about 40 km. So if i configure my position this way: xx.xx i will have an accuracy of 1 km - i think this is good enough. No benefit if i make higher precision.