OpenWeatherMap widget for HABPanel

habpanel
widgetgallery
Tags: #<Tag:0x00007f51e4bafe40> #<Tag:0x00007f51e4baf968>

(Walt Jones) #125

Just following previous posts in this thread…maybe I am wrong…I thought the Samba share of /conf/ was the same as /conf/ as accessed by my Pi3 running openHAB. Am I wrong?

so confused


(Ahnyerkeester) #126

Oh yeah. OpenHAB has a pretty steep learning curve. I set it up, got confused and frustrated, dumped it and went to another platform, found it too limiting and came back to OpenHAB. But once you get used to it, it works.

Are you the one who is running OpenHAB on Docker? I started that way and then scratched it and did a clean install. If you’re using docker, it should be the same but maybe there are some differences I never made it to. Still, it seems that adding a widget should be the same no matter what.

So I think the best way to go is to start with the baseline. Delete the widget set up you have so far, reboot the RPi, and start over. Just follow the instructions and post a screen shot of your results. We can troubleshoot from there.

Sound like a plan?


(Walt Jones) #127

Thanks again…
I did not use docker (don’t even follow what is going on there). I have reinstalled openHAB 2-3 times and cannot get this to work. I am using a Pi3 B, Raspbian Stretch and adding the files/folders to the samba shares via a PC running Windows10. I have the files/folder structure exactly as noted. The only things I did different was to set up the folders and unzip things on my PC and then copy them to the locations. Would this be the issue?

WJones


(Ahnyerkeester) #128

It could be! Might mess with the permissions on some of the files.

I’d recommend doing the work from the command line on the RPi. Might not be the problem, but it might be too. Hard to say for sure till we try.

And I zapped and reinstalled OpenHAB about three times trying to get it work too!


(Ahnyerkeester) #129

BTW, I should have said that it probably fine to download the zip file to your PC and then copy it to the SAMBA share. Just unzip in on the RPi to make sure.

Just to be clear.


(Walt Jones) #130

I will give it a shot tonight…thanks.

If I wanted to start completely over with re-imaging openHabian to a card, is there a way to back up the HABPanels other than the one with the OpenWeatherMap widget? I hate to have to create the others I have over.

Thanks


(Ahnyerkeester) #131

Not that I know of. I know on my last re-install I had pretty good practice on setting up the HABPanels so I whipped through it pretty quickly and the second shot at it helped me get it set up even better.


(Homer Sim) #132
openhab> things list | grep openweathermap
openweathermap:weather-api:4cb4dd5f (Type=Bridge, Status=ONLINE, Label=OpenWeatherMap Konto, Bridge=null)
openweathermap:weather-and-forecast:893c3708 (Type=Thing, Status=ONLINE, Label=Wetterinformationen, Bridge=openweathermap:weather-api:4cb4dd5f)

That is mine


(Homer Sim) #133

under channels there is only at headlines or contend headlines these <> (twist by 90°)
But under control all values are shown … so there must be a link?!


(Homer Sim) #134

I added now the own.controller.js and receiving the same picture


(Scott Karns) #135

Have you followed the instructions from the first post in this thread? From my reading of those instructions, there is nothing that instructs you to manually copy the JSON for the HABPanel widget into ${OPENHAB_CONF}/html/. Per the instructions:


(Bydlo) #136

@bastiaan_van_h In your widget: date:(config.config.day_format == NULL should be date:(config.day_format == NULL to be able to apply custom date format? (double config.)


(Homer Sim) #137

It was may first time I wanted to use it. I installed the binding out of openhab because there is written “if you update” …

The only difference I see in items file is this :local:

{channel=“openweathermap:weather-and-forecast:2fd1295b:local:forecastHours72#condition-id”

which is not in my openhab things channel


(Homer Sim) #138

changed it in items file … no effect


(Ahnyerkeester) #139

Here’s what mine shows:


What I’m concerned might be missing in yours is the Weather_OWM_Condition thing. Are you seeing that?


(Homer Sim) #140

Do you have the items file in addition?


(Ahnyerkeester) #141

Yes. But you have to have the Things linked so that the Items can pull the data from the OWM Binding. If you didn’t link the Things to a channel there are no items for the items file to interact with.

After you get the Binding working, Things should appear in your Inbox or you can add them manually. Those things now appear in the Things folder. But next you have to bind them to a channel. Click on the thing and it will show the channels. Click on the channel to link it. Should see something like this:
15%20PM

With this widget, you don’t need all of the Things the Binding makes available. Look at the items file and see which ones are use. Link those.

Let me know if that makes sense and if it helps at all!!


(Homer Sim) #142

This looks to be the problem.

I unistalled all restarted and redid the instruction.

After adding the thing I see all channels under config/things but there is no editing pen behind each channel to do a linking. There is only a buttons to link and unlink (each are active) but no possibility to make a choice what to link

under controle I see all channels


(Ahnyerkeester) #143

It had to either be the items file or the Things themselves. Glad we found it!

Click on the circle button icon next to the name. That should bring up the Link channel dialog box. Pull down and select + Create new item… for each one.
54%20PM


(Homer Sim) #144

klicking the button just untick it and a message box comes up with “unlinked” or “linked” when switching on
No menu