[openWebNet/BTicino] openHAB3

No one?
So, I assume that it’s not a simple task … :frowning:

well i think everyone here doesn’t use the new app … did you had a look at a lamp if you edit it does it have an indication like area and point ? What you can also do is load my home suite and scan the bus but without any names so you will have to figure out that yourself.

Hi,
Having purchased the server now, I don’t think I have a choice , do I?
Apparently I am forced to use the new apps.or not?

I do not know about the new app (and I did not find docs about it), but in the binding README you can find this information:

I managed to get the addresses. Thanks.

Now I am trying to add a F520 (energy meter) but I need help in reading the energy from it.
I have been able to read the instant power, but not the energy.

Can you tell me what is the channel for reading the energy?

thanks

afraid is not possible for the moment that is what i read aswell the instant watt but i can be wrong.

It’s really a shame, as the F520 is an energy meter, and I thought it could read energy and not only power.

Actually reading in the specs the F520 seems to be capable of reading the energy:
image

It can read on hourly/daily/monthly data … :slight_smile:

Now just need to understand how to retrieve this info to OH…

right now the openwebnet binding supports reading instant power but not energy values.
According to the openwebnet documentation there is the possibility to read also statistics about energy. However this is not in the immediate roadmap, need a volounteer developer.

OH 3.4.0M3 has been published .
For openwebnet it brings:

  • support for basic Scenarios (WHO=0)
    With this enhancement it will be possible to detect basic scenario activation events (for example from F420) on the BUS to trigger rules in openHAB.
1 Like

Hi,
after deleting all my Alexa commands (my mistake :frowning: ) there was no discovery of my Openhab items on Alexa anymore. I did an upgrade from OH 3.2 to 3.3 still nothing.
I discovered that one must add {Alexa=“function”} to the things config. Discovery was fine but now I have a problem with my rollershutter which used to work fine.
Alexa now has the options to OPEN, CLOSE or Percentage. Before OpenWebNet’s auto calibration did a first run and then the rollershutters were moving as told.
Now I get an error: Alexa, open Rollershutters 2 %

[INFO ] [.handler.OpenWebNetAutomationHandler] - Command 98 cannot be executed: unknown position or shutterRun configuration params not/wrongly set (thing=openwebnet:bus_automation:MH200N:Buero_Rollo_N)`

ShutterRun Auto should be default, but also defining shutterun=AUTO doesn’t fix the problem.
It seems that the systems forgets the position of the rollershutters after calibration as I often get messages like “98 set to undef” afer running a command.

Is this an Openwebnet or Alexa problem?
Any hints?

Regards,
Chris

Try setting shutterRun=AUTO and then send via UI (not via Alexa) a % command.
This should trigger automatic calibration with a complete full up-down cycle, and at the end of the calibration the shutterRun should be changed to the correct value.

If this does not work try setting by hand the shutterRun to a value measured for example using a stopwatch

Hello,
I got a strange issue today, I could not change the setpoint of my heaters. In the log I could see some line with :

[er.OpenWebNetThermoregulationHandler] - handleSetpoint() CMD is not connected

I restarted openhab and it’s working again.
I don’t know if I should report a bug? I guess if something is not connected, it should try to reconnect!?

Reconnection is already implemented.
In your case I think you experienced some edge case maybe too difficult too reproduce. Otherwise if you can reproduce it, feel free to report a bug!

1 Like

hello everyone and welcome back after 3 years that the configuration on OH 2.5 works wonders.
These days I have installed OH 3.3 on an RPi4 and I have installed the new OpenWebNet building. Apparently everything is simpler at the graphical interface level, but in doing two tests on thermoregulation (the thing I need most) I noticed that now the single zones can only be set on MANUAL, PROTECTION and OFF. I can’t find a way to put the single zone back in AUTO mode (i.e. with the last programming of the control unit). I have also armed the 99 zone control panel, but from it I can only force all the zones at the same time to take the programming. For me, the function of being able to manually set a zone, and then put it back to automatic without having to do it from the control unit, was very convenient.
Am I doing something wrong? Or on OH 3.3 has the possibility of putting the single zone back in AUTO mode been removed? Thanks to everyone for any tips … I have been looking for a solution on the forum for 5 hours, but I could not find anything.

Ciao Massimo,
I can help you. Will contact you privately.

1 Like

@emiliano welcome on OH 3.3!
Your test is correct: at the moment a thermo zone cannot be set back to AUTO with a command; this used to be possibile in the 2.5 version.
Maybe @aconte80 (who took the task to rewrite and test the Thermo function for OH3) can have a look? I have no Thermo function at home, so for me is very difficult to test all cases.

Meanwhile @emiliano would you mind adding a new Issue on GitHub?

Hi Massi, thank you very much for your reply.
Can I install the binding you made for OH2.5 on OH3.3?
Without being able to return the single thermostat to AUTO, I do not find this binding useful. I try to explain myself: on the old binding I could not modify the control unit (but in the end the control unit does nothing but act as a chronothermostat for the zones that are set in automatic), but instead it was very useful to be able to manually put the zones I wanted to force (like I stay at home one day and I want to heat the tavern, here I put that probe in manual and when I stop using the tavern I put it back on automatic). I don’t know why only 3 states were put on the zones, when in reality the protocol foresees 4 (i.e. OFF, PROTECTION, MANUAL, NORMAL). Where NORMAL is intended as operation dictated by the control panel.
I add the thread on github, thank you very much and good evening!

no, the 2.5 version of the binding is not compatible with OH3

If I remember well this was mainly because this case was difficult to test in practice: in Andrea’s system there is no such configuration (all thermostats are independent)

Damn, so you advise me to stick with OH 2.5? If needed, I can test everything you need. I have a system with 120 light points, 16 shutters, 8 sound diffusion zones, alarm system with the old control unit, 15 heating zones, 2 of which with fan convectors, 3550 control unit, load control. I’ve been looking for a complete configuration for years, but I found the balance with your 2.5 because at least the thermoregulation works well. If you plan to add temperature control with the auto function on individual zones, try me as a beta tester :slight_smile:

since we cannot say if and when this feature will be added (it depends on other priorities and available volounteers developers) and since this feature is so important for you, I suggest to use OH2.5 until at least is available for testing.
No other user has asked this missing feature so far, if I am not wrong.
Remember to add the feature request to GitHub, so you will be able to track progress.