org.eclipse.smarthome.links:autoLinks=false not working/set?

  • Platform information:
    • Hardware: ODROID-XU4, armv7l, 2GB RAM
    • OS: Armbian (Debian) Buster with Linux 4.14.180-odroidxu4
    • Java Runtime Environment: Azul 8
    • openHAB version: 2.5.5-1 from (stable)

I have edited /services/runtime.cfg to contain the following as of weeks ago (upon installation):


However only today noticed in PaperUI this “Item Linking” setting is still set to “Simple Mode”?

Therefore it appears to me as if my setting did not take effect?


I have never edited runtime.cfg. I know there were many path changes for 2.5.x removing many eclipse paths.

That line is commented out in my runtime.

openhab@debian-01:/etc/openhab2/services$ grep links *
runtime.cfg:# In simple mode (autoLinks=true), links and their according items are automatically created for new Things.
runtime.cfg:# Existing links will remain untouched. (default is true)


Thanks for feedback @Bruce_Osborne.

This is my second or third time around re-doing OpenHAB from scratch, and this time I am trying to maintain a purely text set up, from zero, so as to be reproducible and also able to be kept in a repository, with change logs, etc…

All of those lines are commented out, initially. However I have made a number of changes in there (and other files) which (seem to?) have been taken up just fine, for example (personal info removed):


But the particular change in title/OP does not seem to be taken up for whatever reason. Puzzling. :thinking:

OK Perhaps @rlkoshak has some ideas. I do initial setup using the Dashboard UI.

I appreciate the reply and effort, @Bruce_Osborne.

I think my Stallman impression in other thread is getting on Rich nerves right now. :laughing:

Plus I know he recommends PaperUI anyway, over textual configuration.

So I will be interested to see if he responds to your summons. :smiley:

1 Like

I’m afraid I won’t be if much help. The best I can offer is that there is a typo or something in the parameter name. When you supply an unknown parameter OH just ignores it. So if you have a typo there will not be a error.

You can look in the files in /varr/lib/openhab2/config/org/openHAB and see what openHAB is actually using as it’s config. All the cfg files get rewritten out to those and sometimes errors occur in the translation.

I will also note, because far to many have a false impression on this, that all openHAB configs are text based. They can all be checked in to source control. The difference is their location (I. e. userdata) and format.

I usually don’t do much on the forms on the weekend is the source of the delay in response.

As for why do I recommend configuration through the REST UI (it doesn’t have to be PaperUI)? Because problems like this don’t happen.


I wonder if settings in this form actually still work, given a general migration away from eclipse smarthome naming in OH2.5

1 Like

But then their illustrious testing would have caught it before releasing as stable, correct?? :rofl: :rofl:

OK, the behavior in PaperUI seems a bit different than what I remember it. Now when I click on “Item Linking” toggle it just goes from off to on but always says “Simple Mode” where before I seem to recall this text changing before. Anyway, not sure if significant.

Thanks for the suggestion, Rich. It got me looking in the right neighborhood and saved me trying to look up this information (I am not even sure where I would find such information).

Anyway, this is what I did:

trs80@odroidxu4:/var/lib/openhab2/config/org/openhab$ cat *
binding="[all my bindings]"
dayset-school=( \
  "MONDAY", \
  "TUESDAY", \
  "FRIDAY", \
dayset-weekend=( \
  "SUNDAY", \

… both before and after making the change in PaperUI (even waited a bit, made sure to hit Save, etc.) but I did not see any change in the information in any of these files.

Therefore perhaps rossko is on to something here?:

If it has moved, it would be at org.openhab.links now.

OK, this is interesting.

When I put the following in /services/runtime.cfg:


I can see changes in the following file:

trs80@odroidxu4:/var/lib/openhab2/config/org/openhab$ cat links.config 

… but NOT in PaperUI! In there I still get “Item Linking / Simple Mode” set to “OFF” even after refreshing the page, and “Items” is still visible in Menu -> Configuration…

However, if I comment that out, and instead put the following in /services/runtime.cfg:


… then I get the changes in PaperUI, but NOT in the aforementioned file…

Anyway I think this is just an interesting side note. Insofar as my problem in OP, I am a bit embarrassed to say I think it has actually been working fine the whole time(?), and perhaps I was just mistaken due to (I don’t know what?). Because I think the only changes are (as I mentioned above):

  • “Items” present in Menu - Configuration, and…
  • “Item Linking / Simple Mode” toggle set to OFF in PaperUi

And I already have that. In fact, I think I had it all along… :frowning_face: So, sorry for the confusion…

1 Like