OSRAM Lightify Openhab2 Binding

I probably need both directions to have something useful but we’ll see :slight_smile: Give it a try for now.

sent you a PM with a wireshark protocol

Hi,

thanks for the module! I am completely new to openhab, I switched yesterday from FHEM. I installed the build from your dropbox-link, connected it to my Lightify-Gateway and it instantly found all Lightify-Devices and Zones.

Unfortunately I am not able to switch the lights in openhab and it can’t read the current state although they are being displayed as online.

In the logs I can only find messages like this, but no errors:

lightify_bulb_7a488aff_59CDC90000261884_rgbw_power changed from ON to OFF

Is there any way I can debug this?

Nothing in the logs Seems, that it is not loaded. Wrong directory or missing startup options? Or maybe wrong version (I have openhab 2.0.0 and your addon has 2.1.0)?

Seems like I got the same issue right now, I wonder if there was a firmware update. I’ll have a look into it.

Normally it should just work, as you can read from the others. The version doesn’t matter as long as it is at least 2.0, I just used 2.1 because it’ll probably end up in the 2.1 distribution.

1 Like

Updated the JAR file and fixed the bug with not actually changing the status of the lights.

Had to go to the console and enter:
bundle:install file:///usr/share/openhab2/addons/org.openhab.binding.lightify-2.1.0-SNAPSHOT.jar
bundle:start BUNDLEID
Now the bulbs and zones show up as things. Great!

Did the directory exist when you first installed it? This directory is (I think) very specific to the Debian / Ubuntu packages but I’m happy it works now. Used the new version from yesterday? :slight_smile:

Yes, it existed.

weird :slight_smile: no idea, but it works now

Thanks for the fast response. I installed your new JAR, but it didn’t help.
It seems that the binding doesn’t work at all anymore.
I have removed all Lightify devices and the bridge and re-added the bridge.
Btw. last time and this time the bridge could not be found automatically but I had to define the IP manually.
Last time the bridge was being displayed as online and all Lightify devices were added to the inbox. This time the bridge stays at “Status: UNINITIALIZED”.

I have restarted the openhab-service many times during this journey…

If it is on uninitialized, there should be a reason why. I just changed one line of code. Try to unlink channels, then delete the items (which were linked previously), delete the bridge and the JAR file. Restart openhab and reinstall from a clean state, it probably stucks in a bad state somewhere. Especially unlinked channels gave me plenty of issues with different bindings in the past :slight_smile:

Same for me - lightify bulbs cannot be controlled via this binding.

Did you download the new version from dropbox? I re-uploaded it, maybe it didn’t exchange the version.

https://dl.dropboxusercontent.com/u/17040722/lightify/org.openhab.binding.lightify-2.1.0-SNAPSHOT.jar

Please delete the old version, remove all old things / items / channels (according to the previous post, the order is important) and start over.

Thanks, the lightify gateway is now connected successfully again and I can see all lights. Under “control” lights are not showing any state (everything shows “off”, light level “-%”,…)
I tried switching on one light, that was already running and it didn’t change anything. Turning it off afterwards worked. Turning it on again didn’t work anymore, but after setting the light level to 70% the lights turned on again. Playing around with light level or color temperature afterwards didn’t change anything again and turning the light off also didn’t work anymore.

Weird, it works nicely for me. Do you have anything else except light bulbs? Do you only use Lightify blubs or compatibles?

German speakers are free to join https://slackin-jvm-german.herokuapp.com/ and the “smarthome” channel. Might be easier for quick trial&error :slight_smile:

I tried what you suggested and could switch on and off one bulb once. Afterwards: No function!

What is the “german” forum about? Didn’t want to register…

It works for me since days, without a single restart, I don’t understand way. As I asked before, any other devices (except official Lightify bulbs) paired with the gateway?

About the Slack, it is not required, just asked if a German speaker would like to join. Realtime discussion, makes it easier to trial&error, no necessity though :wink:

Nothing else paired. However, the Lightify Gateway is paired with my Homematic CCU2.