Own cloud + OH3.1

Tries to install subj. All working well except OH main UI administrator login (bottom left corner icon). When I pressed under cloud host - got 404 with ‘Cannot GET /auth’ message.

My setup:

  1. nginx container forward all wan traff to ‘cloud container’ 3000 port
  2. Cloud container with node app (latest from github) - 3000 port
  3. OH3.1 container with 8080 port

Looks like cloud container does not proxy traf for /auth url but I don’t know why

Only for me or well known bug? )

There aren’t many people who use their own clouds instead of myopenhab (or reverse proxy). Of the small number who do, it’s possible that none of them have been here recently to see your post.

post your nginx config so that others could review it.

Front NGINX (portf-forwarder from ISP)

root@front:~# cat /etc/nginx/sites-enabled/openhab 
#################################
# openHABian NGINX Confiuration #
#################################

## Redirection
#REDIR server {
#REDIR   listen                          80;
#REDIR   server_name                     DOMAINNAME;
#REDIR   return 301                      https://$server_name$request_uri;
#REDIR }

## Reverse Proxy to openHAB
server {
#SSL   listen                          443 ssl;
    server_name                     <secured>;
    client_max_body_size 300m;
#SSL   add_header                      Strict-Transport-Security "max-age=31536000; includeSubDomains";

    # Cross-Origin Resource Sharing.
    #add_header Set-Cookie X-OPENHAB-AUTH-HEADER=1;
    #add_header 'Access-Control-Allow-Origin' '*' always; # make sure that also a 400 response works
    #add_header 'Access-Control-Allow_Credentials' 'true' always;
    #add_header 'Access-Control-Allow-Headers' 'Authorization,Accept,Origin,DNT,X-CustomHeader,Keep-Alive,User-Agent,X-Requested-With,If-Modified-Since,Cache-Control,Content-Type,Content-Range,Range' always;
    #add_header 'Access-Control-Allow-Methods' 'GET,POST,OPTIONS,PUT,DELETE,PATCH' always;

## Secure Certificate Locations
#CERT   ssl_certificate                 CERTPATH;
#CERT   ssl_certificate_key             KEYPATH;

    #add_header 'Access-Control-Allow-Origin' '*' always;
    #add_header 'Access-Control-Allow_Credentials' 'true' always;
    #add_header 'Access-Control-Allow-Headers' 'Authorization,Accept,Origin,DNT,X-CustomHeader,Keep-Alive,User-Agent,X-Requested-With,If-Modified-Since,Cache-Control,Content-Type,Content-Range,Range' always;
    #add_header 'Access-Control-Allow-Methods' 'GET,POST,OPTIONS,PUT,DELETE,PATCH' always;
    #add_header Set-Cookie X-OPENHAB-AUTH-HEADER=1;

    location / {
        proxy_pass                              http://192.168.10.71:3000/;
        #proxy_buffering                         off;           # openHAB supports non-buffering specifically for SSEs now
        
        proxy_redirect off;
        proxy_http_version 1.1;
        proxy_set_header Host $host;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
        proxy_set_header X-Real-IP $remote_addr ;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for ;
        proxy_set_header X-Forwarded-Proto https;


    }

    listen 443 ssl http2; # managed by Certbot
    ssl_certificate /etc/letsencrypt/live/<secured>/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/<secured>/privkey.pem; # managed by Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

}

server {
    if ($host = <secured>) {
        return 301 https://$host$request_uri;
    } # managed by Certbot


    listen                          80;
    server_name                     <secured>;
    return 404; # managed by Certbot
}