Pages overview defaults to empty

I have migrated from OH2, and I’ve started to fill my semantic model. However, the overview page is not generated from my semantic model. I can add to the page, but the default layout seems to be corrupted.

I don’t get the prefilled widgets from the semantic model, and there are no tabs at the bottom. My semantic model does contain locations, the locations contain equipment, and the points in the equipment contain tags.

When I go to the code section of the overview page, I get this:

  label: Overview
blocks: null
masonry: null
grid: null
canvas: null

I have tried to save changes to the code, but it always goes back to the above default.

How do I get the automatically generated overview page?

There are four tabs in the Overview page. The first one is a custom layout page that you need to populate from scratch yourself.

The Locations, Equipment, and Properties tabs are the ones that are populated from the semantic model.

Hi Rich,
I appreciate you taking time to answer my question. I did read the manual though, and those tabs are not visible. I just have the header “overview” and no tabs. Something is wrong with my installation, and I would like to find out how to fix it.

There are really only two reasons why the model tabs would not be displayed: 1) your semantic model is not configured correctly, or 2) somehow you have set one of the settings that hides the tabs from certain users (or hides them altogether).

Things to check for case 1:

  1. You say your model is correct, but how do you know this if the items do not show on the tabs?
  2. Did you make you model items with files or through the GUI? Applying the semantic model to items through files can be very difficult and is usually very error prone.

Things to check for case 2:
When you click on the small pencil icon in the upper right hand corner of the overview page there is a configuration page that looks like this

  1. Make sure that the Display model cards setting has either both options unchecked or that the checked option includes the role of the user that you are currently logged in as.
  2. Make sure that none of the model tab types are checked under the Hidden Model Tabs setting.

Beyond that, check your browser’s developer tools to see if there are any errors reported when you load up the page.

It was client side. My adblocker was somehow preventing the tabs from being displayed. Works as expected now.