Panasonic Comfort Cloud binding [3.3.0;3.5.0)

Indeed in the initial logs it were only some internet downtime on my side. I added debug logs of when it goes into error state with proper internet connection.
The solution with ESP32s looks nice, but maybe overkill for my application. Using the PCC service is sufficient for me, just a pity that it goes into this error state regularly. It seems strange that the Thing cannot recover from this automatically once PCC service is available again.
For now I fixed it by disabling & re-enabling the Thing with a script when this issue occurs.

Hello Community,

ive installed OH4 onto a proxmox VM to move my system from the RPi3 to a more relyable HW-Base.

Is there a OH4 support of this binding? I´ve tried the last OH4 build on my OH-System (Release Latest Build · seime/openhab-panasoniccomfortcloud · GitHub)
but i cant setup the panasonic comfort cloud bridge.

Im getting a little weard esphome remark

and inside the binding the information

Does anyone has oh4 experience with the binding?

A little copy paste error there :wink:. Im also doing the ESPHome binding.

It should work on OH4, could you attach the logs?

Edit took a closer look, seems like Gui condition has a problem. Did you try with file config?


Log seems to be inconspicous. What you mean with the config? Withing addons.cfg?
Not tested jet, im also not sure about the syntax of the binding.

Within the OH3 it was not needed.

Unfortenly im also not the linux pro user ;-/

A thing file like from the README

Anyways; I updated the binding. Remove and install the binding again and you should be able to add things manually via GUI.

1 Like

Big thanks for new build. The bridge/device is now createable.

Note: Im getting a communication error:


  • Error fetching data: Error sending request to server. Server responded with 400 and payload {“code”:“4000”,“message”:“Missing required header parameter or bad request for header”}

App-Version 1.18.0, PW and useraccount double checked. The ComfortCloudApp is working with the same login from the same network. Something changed on Panasonic side? Try again later?

Same here:

My config worked (a few months ago) with my OH3 config. I use textual configuration and copied the things-file from OH3 to OH4 and added the file ‘no.seime.openhab.binding.panasoniccomfortcloud-4.1.0-SNAPSHOT.jar’ to the adding-directory.
The only things I’ve changed in the things-file is the appVersion from 1.17.0 to 1.18.0.

Can confirm the same on my side. Something changed in the API again.

I’m running short on time, so if someone could try another tool and see what the http traffic is and figure out the difference, I can update the binding (or even better; create a PR)


I saw this in a related conversation - maybe it helps? ( Invalid response, status code: 400 · Issue #78 · lostfields/python-panasonic-comfort-cloud · GitHub):

The REST call needs some additional headers:
X-APP-TYPE:1 X-APP-VERSION:1.18.0 Accept:application/json; charset=utf-8 Content-Type:application/json User-Agent:G-RAC X-APP-TIMESTAMP:1 X-APP-NAME:Comfort Cloud X-CFC-API-KEY:Comfort Cloud
The last three are new for me.

@Jaco @Klommer @mri_ice A new version is available in the regular location with the fix suggested by @mri_ice . Thanks!

Solved the problem, binding is online and airconditioner controlable again. Thanks all! @mri_ice

Same, up and running again. Thank you yet again for providing & maintaining this bundle @seime , it’s much appreciated. Thanks for the quick fix.

Binding is online again. Thanks for that :+1: But the channel for current indoor temperatur is not updating anymore :thinking: Even if the device is running.

Hi, just wanted to mention that I could connect my Panasonic airco, type: CS-Z71VKEW.
Well, I could read the inside and outside temps. Still learning how to set up OpenHab.

Hi, I am having an issue setting up my AC unit in OH4. I have the binding installed and the bridge is online but when creating a thing for the AC unit it is giving a device ID error as shown below. My AC model is a S-71PE1R5B and connected is a CZ-CAPWFC1 wifi module. With both of these I have the serial numbers off the units. The AC has a 10 character serial number that’s both numbers and letters and the wifi module has a 7 digit serial number. I’ve tried “S-71PE1R5B+serial number”, “S-71PE1R5B”, “CZ-CAPWFC1+serial number”, & “CZ-CAPWFC1”. Have I got my device ID wrong or is there something else I am missing?

@edwardjelley did you try to add a new thing by scanning?
I clicked the + button on the Things page, select Panasonic Comfort Cloud Binding and click the blue Scan button. It then found my airco.
But I didn’t have my serial number.

Seems like some calls now have started hanging (apparently request it sent, but no data returned, log is quiet).

I’ll dig Into this later