Panstamp and openhab2

Hello,

I just switched from openhab 1 to openhab 2.
Unfortunately I was not able to get panstamp binding to work yet. I downloaded openhab1 addons zip and installed panstamp binding jar to openhab2.

Unfortunately I don’t have access to my openhab.log but it shows an undefined reference to gnu.io at startup of panstamp binding. I checked the net but couldn’t find out what exaclty is missing.

Was anybody successfully using panstamps with openhab2 yet?

If the README for the binding does not appear in the docs then no one has reported yet whether or not this binding works with OH 2.x

Did you follow the instructions here and install the compatibility layer?

Without the logs we are very limited in any advice or debugging help we can provide.

With the information provided thus far either you haven’t installed the compatibility layer yet or OH 2 is missing a library that the binding depends upon.

Please keep us up to date on your progress. If you get it working we can make it part of the distro and in the future it can be installed from PaperUI.

The readme appears in the docs here section of openhab2 so I thought it should be possible to use it on openhab2.

I never installed the compatibility layer but did it now. Unfortunately it didn’t change anything. In fact I’m currently wondering why other openhab 1 bindings were working.

My log shows the following at startup:2017-10-14 07:25:32.204 [ERROR] [org.openhab.binding.panstamp        ] - FrameworkEvent ERROR - org.openhab.binding.panstamp
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.panstamp [10]
  Unresolved requirement: Import-Package: gnu.io
	at org.eclipse.osgi.container.Module.start(Module.java:444) [?:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620) [?:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1600) [?:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571) [?:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514) [?:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1) [?:?]
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230) [?:?]
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340) [?:?]

I guess that your assumption with missing library is right but couldn’t figure out which one. Thought it is rxtx but installing it didnt help me.

I must have missed in when I searched. In that case I believe it has been tested and known to work. However, it is listed as a legacy/manual so I believe you need to have the compatibility layer installed for it to work.

Those not labeled manual/legacy have been tested and modified to work in OH 2 and do not require the compatibility layer. It is only those that have not been tested and modified to work without the layer.

I don’t know this binding or the libraries. It would seem to me that the gnu.io library would come from somewhere else with a package like gnu.io. I found this link that might be helpful.

https://www.eclipse.org/forums/index.php/t/1086581/

Beyond that, I’m not going to be much more help. Good luck!

I actually got it working (more or less).

The thing that missing was openhab-transport-serial. After installing that via karaf Panstamp binding is loaded successfully and also items are updated for default devices like official temphum board.

Unfortunately I have still some issues that the raspberry pi hangs at reboot if panstamp modem is connected and I still couldn’t find the place where to store device description files so they are used.

Once I get it up and running stable I will update this post with all things that are necessary. Maybe they can also be added to the readme.

Additionally it would be great to see panstamp binding ported to openhab2. I’m SW-developer but java is not my biggest strength so I don’t see myself being able to take up that task.
But if someone is taking up that I can offer myself to help and support in development and testing.

I use openhab 1.8 together with some panstamp device for several years. Now I want to upgrade to openhab Version 2. But I missed a working panstamp binding.

During the last days I tried the panstamp plugin in openhab 2.2. rlkoshak comments helped me a lot. I activated the legacy mode and added an 1.10 (1.8 plugins download) panstamp binding. In principle it worked …

  • The panstamps are connected (sending and receiving data)
  • Custum device descriptions can be used. I add the line panstamp:directory.xml=/home/pi/pan_stamp_devices to the openhab.cfg in the service directory.

But there are still some Error messages:

  • During startup: Failed installing ‘openhab-binding-panstamp’: Error restarting bundles:
  • And when I stop openhab I got an exception from me.legrange.swap.tcp.TcpServer about a closed socket.

Since I am using a mosquitto MQTT broker, I tried lagarto-swap, https://github.com/panStamp/panstamp/wiki/lagarto-swap. But that python tool lost the serial connection to the panstamp several times during testing.