Paper UI - Basic Z-wave Switch and LIFX seup

lifx
paperui
switch
Tags: #<Tag:0x00007f013fe83ec8> #<Tag:0x00007f013fe83d60> #<Tag:0x00007f013fe83ba8>

(Ashton Harvey) #1
  • Platform information:
    • Hardware: Raspberry Pi 3b w/ Aeotec Gen 5 USB
    • OS: OpenHabian
    • Java Runtime Environment: n/a
    • openHAB version: 2.4.0-1 release build

I am trying to setup a basic local control light switch as my first step into OpenHab and I spent an embarrassingly long time trying to get something simple to work. I have a set of LIFX wifi connected lights that I want to have controlled by the GE Z-wave switch in the same room. I have the bindings for the z-wave controller and LIFX working and the switch and lights added. I can control the switch and light and they are linked. If I switch one light on in the panel, they all turn on and vice versa. The switch also changes states with them. When doing so from the control panel the lights come on and off as expected. My issue is that when I use the physical switch, the control panel shows the state change for the switch and lights, but the lights don’t come on or go off. It seems like the command is not being sent to the lights. Does anyone have a suggestion on how to resolve this?

Control Panel


Things

Bindings
image

Items (long list, just kept the import parts):



(Rich Koshak) #2

You may need to set the auto update to forcing on the zwave item. I suspect that when you flip the switch it just updates the Item. Updates Only update the Item a d do not get forwarded to the other bindings linked to that Item.

It would require moving your Items to. items files, but this is exactly the use case that the follow Profile was created to solve. https://www.openhab.org/docs/configuration/items.html#profiles


(Ashton Harvey) #3

It took me a long time to understand exactly what you meant here, but I made some great progress learning the Basic UI vice paper UI in the process, thank you very much for your help! That said, for those who find this and want to understand how to easily link your LIFX Lights to ‘follow’ a switch like this, the image below is where this setting for follow mode is buried.