Paper UI & Habmin

I recently did an upgrade to openHAB2. I just followed the standard tutorial to migrate my things from openHAB1.
Now I’m trying to change some configuration through PaperUI or Habmin. But nothing seems to save to my files.
How can I make this work?

Short version: Config changes performed via the UIs will not modify your manual config files. The UIs will store config data in other system locations.

What kind of configs are you modifying using the UIs?

I tried to configure the items that should be available through IFTT. I press save but when I go to the screen again and it’s empty.
I have the same issue when trying to add items.

Does openHAB combine the manual files and the system files? Or how does it work?

If your items have been defined manually in *.items file(s), then you won’t be able to modify them using the UIs. You will need to modify the config text files that you created to change something in there.

Yes, it uses both the Site configuration directory (e.g. C:\openHAB2\conf or /etc/openhab2/) as well as the jsonDB directory (e.g. C:\openHAB2.0\userdata\jsondb)

For more info, check:

Is there a way to migrate your manually created files to the jsonDB so you can modify it?

You could use the PaperUI to define all your stuff (items, etc) and they will be stored in the jsonDB.

There is no direct (meaning convert the configs) migration path from manual configs to jsonDB.

After you have created your stuff using PaperUI, you will then be able to modify them there (on the PaperUI).
Optionally, you will also be able to manually change the jsonDB files (it is not really recommended to touch the jsonDB and this should be avoided).

I will just keep on using the old way of working then. Then I don’t have to rework everything. :slight_smile:
It would be nice if there was kind of a migration path from the files to jsonDB without lot’s of manual work (and maybe the way back for backup reasons)

I just have been going through this migration with my 50 + node OH 1.8 setup. As part of that migration, excluded all my devices from a z-stick gen 2 to a z-stick gen 5 (because Aeon supports backing up the gen 5 but NOT the gen 2).

The whole configuration via PaperUI vs text files for items choice space is a mess. I’ve gone back to a clean openhabian install at least three times, one of which occurred because the jsondb storing the config info got corrupted and the backup was unrecoverable. (so heads-up on that).

Here’s one thing to be AWARE of on the UI side. IF you have a textual items file, those items will appear on the PaperUI Control Panel (and on Habpanel) ---- you can create a widget but that widget will NOT operate the thing at least in the case of z-wave devices. You still have to use PaperUI to create the channel links …EVEN IF you had valid channel links in the item descriptions (found this out the hard way when recovering from the jsondb crash. Someplace there’s a “hole” in the supposed transparency of using textual items files. (which I am doing because all of my automation rules refer to the item naming style I used in OH 1).

Best strategy for those in similar situation (at least for z-wave stuff):…

  1. Get your controller with everything included. Write down the order of devices AS YOU DO the inclusion.
  2. Start up OH2 with controller in USB slot. NO items file yet.
  3. Add the z-wave binding and let it do discovery. It will take a while. Accept the Inbox items as Things.
  4. With battery-devices (door sensors etc) you will need to “kick the sensor” by operating the door a few times (or pulling the battery for a few seconds and reinserting it, also a few times). Only when the binding recognizes the specific device make/model in the Things listing can you go further with that particular Thing.

Now get your items file in a text editor while you can look at the Things listing in parallel. Now, for EACH THING:

  1. Click the pencil icon to the right of the thing. This will bring up the config dialog for that particular thing.
  2. Make the general config change you want for that item…(name, location etc).
  3. Click the checkbox at top to save changes, a new page will appear with the channels for that thing listed.
  4. In each channel will be a descriptor similar to “zwave:device:2a83f6df:node13:switch_dimmer” with a copy text icon next to it. Copy the text.
  5. In the textual item file for the item that you want to map to that channel (eventually), replace the zwave descriptor with: {channel=’'paste the text you copied inside the quotes " }
  6. DO NOT do anything in Paper UI with the channels at this time.

Now drop your corrected items file into the /etc/openhab2/items directory and restart openhab2.

Again FOR EACH thing, edit save through the general thing config page to get to the channels page. Then for channels which you mapped in your textual items file, click the channel icon and in the Link Channel dialog, hit the dropdown and select the name you used in your items file for that channel. Rinse and repeat.

Maybe we should ask for a simple import/export in paperUI and/or habmin. :slight_smile: That would at least make it a whole lot easier. For now I’m working with the files.

I don’t have the same experience…
I never had to use PaperUI to link my Z-Wave items to channels of Things, since the channel links in the text config files work fine (and they appear in PaperUI).

The links (or items) info won’t be saved in the jsonDB if you define them in the config files. Only the Things info will be in the jsonDB.