Paradox EVO Binding

New version has been uploaded.

Backward incompatible changes exist - some channels got renamed due to review requirements, also the static data like serial numbers, firmware revisions, etc is now modelled as properties and not channels.


Hi @Jean_Henning,

Just wondered if you still invest time in reverse engineering this protocol and if you have any progress with partition activate/deactivate commands?

One additional question.
I’ve found that after the login sequence if you wait for around 200-300ms and call receive from the socket, there is a 37 bytes packet received which does not fit into the staging you’ve documented. What I currently do is I just receive and ignore it.
Did you noticed such packet at your system? Do you have any clue what it’s doing?
I’m currently away from home but when I get back I will publish the contents if you’re interested into it.



At the moment I use this OH version: openHAB 2.5.0 Build #1512
If I update newer snapshot, your binding does not work.
I have problems with other bindings as well, like Xiaomi.
It becomes very unstable.

Are you using the JAR or the source code and build it yourself?
I believe in my last push due to requested changes there is a regression in communication part when the binding times out.
I will try to fix it as soon as possible but meanwhile please use the latest built JAR.


EDIT: Just checked. My Openhab is M1 release. Haven’t upgraded since then…

1 Like

Thanks! There are important changes after february I think, that’s why I wanted to update. But it is not that urgent. I use your latest jar file. I installed Eclipse enviroment but I had version problems and I could not fix it. I hadn’t got enough time. Anyway I wanted to make some debug logs for you with the new versions. I can upgrade and put back the original version fast. So if you want, I can do the debug files to see where it stops in the next two weeks. I wil be busy next week and probably I can do it only a week after.

I’m currently busy with other time-consuming stuff outside OpenHAB and that’s why also the pull request is getting delayed. I just cannot contribute right now. Two weeks from now may be the time when I will get more free time so feel free to send me the logs.
When I have time I’ll make sure to also upgrade my own system and test it myself.


Thanks! No problem, we have planty of time. Probably I go back to M1 as well. I’ll make the log soon.

Hi all,
just a quick heads up that the binding has been merged in the main branch so probably you will be able to install the normal way once the milestone has been published.

I’m currently looking how to implement a discovery service so things can be added from the modern UIs. Bridge should be able to do that because what we need initially is just a connection to the paradox system. All the supported types should be very easy to retrieve. Will post when I have progress with that.


Thanks! Currently I’m on 2.5M1. As soon as M2 is released I will try it out. I also test the distro versions time to time but the recent versions were not working for me. System itself was working in the backound but Paper UI, Basic UI were unstable or frozen.

discovery service is also merged in main branch.
Be aware that you need to configure the bridge first and then all entities will be automatically discovered.
Things will be labeled by the ThingTypeUID + the label of the thing given in the paradox system.
Background discovery is disabled currently.

Best regards,

Hello, I have installed openHAB 2.5.0 Build #1645 snapshot. It does not contains Paradoxalarm binding. Plus I can confirm that it works with org.openhab.binding.paradoxalarm-2.5.0-SNAPSHOT seamless.

Hello, Info. I have installed the next snapshot. Paradox binding does not start. Here is the openhab.log: paradox_debug.txt (4.4 KB) I go back the last pervious one. It works with that fine and I will try one next one later.

1 Like

Anyone can help me with this error? Thank you.

019-08-02 10:00:24.625 [INFO ] [l.handlers.ParadoxIP150BridgeHandler] - Found EVOHD panel type.
2019-08-02 10:00:24.627 [INFO ] [al.communication.GenericCommunicator] - Stopping communication to Paradox system
2019-08-02 10:00:24.629 [INFO ] [al.communication.GenericCommunicator] - Waiting the socket to close…
2019-08-02 10:00:25.631 [INFO ] [al.communication.GenericCommunicator] - Communicator closed successfully.
2019-08-02 10:00:25.634 [INFO ] [l.handlers.ParadoxIP150BridgeHandler] - Phase2 - Creating communicator for panel EVOHD
2019-08-02 10:00:25.643 [INFO ] [al.communication.GenericCommunicator] - Login - Login to IP150 - OK
2019-08-02 10:00:25.719 [INFO ] [al.communication.GenericCommunicator] - Successful logon to the panel.
==> /var/log/openhab2/events.log <==
2019-08-02 10:00:39.009 [hingStatusInfoChangedEvent] - ‘paradoxalarm:ip150:cced4079’ changed from OFFLINE to OFFLINE (COMMUNICATION_ERROR): Error initializing panel handler. Exception: Unable to read from socket or received data is wrong.

Thanks for the feedback! I’m currently on my summer vacation without laptop so will have a look at it earliest on Tuesday next week.


The behavior looks like there is difference in protocol between evo48/96/192 and evohd.
To be sure I will need you to raise the log level to TRACE for paradox binding and attach the log here. If this is the case I guess we need to code new communicator for EVOHD if someone reverse engineers the protocol.


…one more thing I just remembered. Which version is your IP150?
After certain version there is no option to directly connect to IP150 but instead you need to use Paradox cloud services. There was somewhere in the net a guide how to downgrade the firmware of it…

Same result with 2.5.0_M2 Paradox Binding does not start. I copied the openhab.log information.
I go back to 2.5.0 Build#1645 snapshot. Binding works with that version. Also I do not see in the bindigs list of Openhab, so the binding is still not included in the distribution. If there is newer version what works with these versions pls share.

Paradox_Binding_250M2.log (151.3 KB)

Witch openhab version do you use? See my reply’s, same problem I have, if I go above 2.5.0.#1645 snapshoot or same with 2.5.0 M2. Try it with 2.5.0 M1 or with 2.5.0.#1645. It will work seamless.

Hm… interesting. It seems that the thing handler factory is not working OK which comes from the framework. After that since the communication stays open it seems the retry cannot connect to the panel, thus making the updates also not working.
I’m again on travel now. Will come home today. Let me get back to you with version I use and maybe I can upload you the .jar I’m using for testing…
When I have time I will update to latest milestone and will test it myself as well.

Thanks! No hurry, I’m fine with working snapshoot. As I use mainy Zwave and Zwave has some issues what will be fixed soon and there are some fix between my snapshoot and M2 I would like to upgrade.