Peanut Zigbee Outlets

I just wanted to drop a quick note to say that I just bought three Securifi Peanut smart plugs. They are not listed as compatible in the binding docs (I know it’s not feasible to list everything there) but the Amazon listing claimed Zigbee HA 1.2 so I gave them a shot.

I’m happy to report I had all three discovered and put into use within about five minutes. It took longer to remove them from the box than it did to get them discovered through the binding. And they react noticeably faster than my GE Zwave appliance modules.

If you have Zigbee and need a cheap ($15) smart plug that report voltage, power and current, I can say that they work like a charm.

Why did I have to get these at the last moment? I didn’t follow the advice on the Tasmota site and leave well enough alone. I had a couple of Sonoff Basics that were running a 2017 released firmware and one running a 2018 year released firmware. Instead of reading the docs I decided to “upgrade all the things!” The 2018 version of Tasmota upgraded just fine. The older ones won’t even turn on now. :frowning: I tried to reprogram them but I think my programmer is broken (the little LED doesn’t turn on). So until I can get an old RPi out of mothballs or buy a new programmer, I needed something to run my Christmas lights. These do the job perfectly. I may not bother fixing those Sonoff Basics after all.

tl;dr: If it’s not broken, don’t fix it. If you decide to fix it, read the docs first. Peanut plugs work fantastically well with the Zigbee binding.


A PR to add them would change that of course :wink:

1 Like

I wasn’t sure if you wanted to keep up a list. I’ll happily submit the PR momentarily.

Yes, I know it’s a bit like chasing your tail, but I think it still helps people out as I often see people refer to it (such as you did :slight_smile: ).


Is it safe to say “If the device says Zigbee HA 1.whatever” it should be supported? Or is that rarely included in the sales listings, or they lie like lying dogs, or Zigbee HA 1.whatever doesn’t really mean much? If there is something like that I could add it to the table and maybe cover a bunch of stuff from different vendors with one entry.


ZigBee HA is obsolete and ZB3.0 is the current consolidated standard. In general from an interoperability perspective, it’s all the same though, and so long as the device supports the clusters/commands the binding knows about, then it will be supported.

So, in general all lights will work if they are ZigBee compliant (pretty much any HA or ZB3.0 profile), but some exotic devices may not - or simply not so exotic devices that I’ve not come across and therefore haven’t added support for.

(I hope that makes sense - yell if not).

I know where you’re coming from, and I try to make the above sort of statement myself (although I’ve not looked what’s written in the docs for a while) but I still think it’s good to explicitly state devices that have been tested. I think it’s less confusing, or more obvious for less techy people.

I think the generic statement, if not already stated somewhere around the table is also useful though.

The generic statement is a little too generic I think:

The absence of a device in this list does not mean it will not work - if the device is a standard ZigBee device similar to ones on this list, then it should work.

But there is enough wiggle room here that perhaps something more specific would be misleading. And the statement that is there plus the table pretty much says the same as you do above, just without mentioning the profiles by name. That’s probably good enough.

1 Like

Thanks for the info @rlkoshak

For anyone else interested here’s an Amazon like to the outlet.

1 Like

What am I missing? I plugged mine in and it shows up but has no channels and thing configuration says “node has not completed discovery”

Platform information: Samsung xe700t1a tablet.
Hardware: intel i5 2467/4gb ram/128gb SSD ~110gb free
OS: Lubuntu 18.04
Java Runtime Environment: zulu java 8
openHAB version: 2.5 RC1
installed\updated via apt

I couldn’t say. It worked perfectly for me the first time every time.

Maybe try doing a factory reset (instructions are in the manual I think) and trying to include again. Beyond that I’ve no ideas.

Already tried that. Same result. I’m stumped myself. It just keeps blinking red and never completes the discovery. Tried plugging some lights to it and turning it on and off to make changes on the channel status but no luck.

All I can recommend is put the binding into debug or trace logging level and capture what get’s saved when trying to pair the device. Post them here and hopefully when Chris has a chance he can review and see if there is anything obvious going wrong. These are my first Zigbee devices and they paired so perfectly I’ve no experience yet with debugging Zigbee problems.

How would I do that?

In addition to the reference above, the binding docs have more specific information -:

Here is a log. I turned on debugging then added zigbee items in my inbox (had removed some to see if that would help) and then located and removed then re-added the peanut plug.

I then did a search in the log file for “debug” and copied everything from the first line that had debug in it.

There’s quite a lot going on in this log so it’s hard to know when you were including this device, or what the device is. Can you tell me the network address of the node that was joined?

The MAC Address? 000D6F000A797C8E for the plug.
I’m using the Nortek husbzb-1 zwave\zigbee combo dongle.

The other devices I paired are a light: mac add E20DB9FFFE0A0174
And a remote : mac add 000D6F000EC8FEB9

I am beginning to think i have a defective unit.
If I can’t get it working today I am going to send it back to amazon.

Is there anything else I should try - maybe a settings change?