Permanently disable openHAB mDNS service

How can I permanently disable the openHAB mDNS service for Homekit? After a reboot of openhab is always active again.

This thread ( Disable mDNS responder? ) suggests to use:
a) a local firewall to block the port

Unfortunately does not work. I put the file org.openhab.mdns.cfg in userdate/etc, then restarted openhab. The service is then still active.