Persistence file error openhab 2.1


evertime I save a persistence file I get the following error:

22:46:37.079 [WARN ] [el.core.internal.ModelRepositoryImpl] - Configuration model 'influxdb.persist' has errors, therefore ignoring it: [1,1]: mismatched input '<EOF>' expecting 'Strategies'

22:46:37.098 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'influxdb.persist'
22:46:37.173 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model 'influxdb.persist'

In this case influxdb.persist. Same behavior with all other persistence files (rrd4j, mapDB). This is the content of the file:

Strategies {
    everyMinute : "0 * * * * ?"
    everyHour   : "0 0 * * * ?"
    everyDay    : "0 0 0 * * ?"

Items {

gPersistence*	:	strategy = everyChange, everyHour


I don’t know what is wrong in line 1. The file seems to work and I the stored values in the DB.

Thank for your help!

This is mine, which includes a default statement (this shouldn’t be the problem, but try to add it)

Strategies {
    everyHour : "0 0 * * * ?"
    everyDay  : "0 0 0 * * ?"

    default = everyChange

Items {
    // persist all members of gInflux Group on every change
    gInflux* : strategy = everyChange, everyHour, everyDay

Same error after saving the file. Any other idea?

It seems, that the update from openhab 2.0 to 2.1 causes a lot of errors and warnings in the log from my setup. The major part is running without any problems, but these problems drive my crazy:slight_smile:

what text editor are you using?
try to recreate the file from scratch using another editor to eliminate the possibility of strange characters being added (I don’t know what else to suggest :stuck_out_tongue:)

The warning you posted points tò line 1 column 1 with an unexpected EOF character.
The file is however read!

Hello Guys

Remove the first blank before Strategies

OH 2.1 is a little bit more sensitive on this.


There is no blanket before Strategies, but after checking the whole file for blankets (especially at the end of every column) there was no more error.

Thank you!

1 Like

can you try this?
rename the file to != .persist and then back to .persist.

1 Like

I observed the same issue. Thanks for the hint. it solved it.

BTW: It’s interesting, that I’m not get an error with a blank line at the end of the configuration when OH2 is starting up, but getting an error after editing the file…

I observed the same, if I edit via Samba. If I restart openhab, the file is loaded without any error message.

May it is the same issue as described for the rules file:

Configuration model 'test.rules' is either empty or cannot be parsed correctly!:

Thus the error message can be ignored.

Best regards


touch <your service>.persistence

after editing addresses the issue, too. Still annoying, though.