Philips Air Binding [;

When I’m back next week from travelling I’ll try to compile a 4.1 version. Don’t know what causes the incompatibility

1 Like

Much appreciated! Looking forward to the new release :slight_smile:

I have a beta version available here

edit 29-1-2024. Also added kar file, which eliminates the need for manual feature install of coap&upnp

I have it working for week now. This should also impove the connectivity issues.
It is still having more debug output… once i test some more I’ll remove it and make a real release.

Thanks for sharing!

Get an error thou after putting it into the addons folder:

2024-01-27 15:56:10.424 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab/addons/org.openhab.binding.philipsair-4.2.0-SNAPSHOT.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.philipsair [275]
  Unresolved requirement: Import-Package: org.eclipse.californium.core; version="[2.7.0,3.0.0)"
	at org.eclipse.osgi.container.Module.start( ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.internal.framework.EquinoxBundle.start( ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle( [bundleFile:3.7.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles( [bundleFile:3.7.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess( [bundleFile:3.7.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process( [bundleFile:3.7.4]
	at [bundleFile:3.7.4]

I think this is due to missing the features. Add them with

feature:install openhab-transport-coap
feature:install openhab-transport-upnp

Hi Marcel,
just installed the missing features. But now there isn’t even a log-entry that the binding has or has not been added. I also don’t see anything new in the Things-Add-Menu.
I restarted openhab after installing the features in karaf, but nothing changed.
Also deleting the file from the addons folder and putting it in again hasn’t changed anything.

I tried to capture the Install-Process in Karaf with log set to debug for everything… If this might help…

yes, pls do. I saw your

which is due to missing the openhab-transport-coap hence the suggestion

Hi Marcel,
thanks for the add-on, is this the command for SSH console, or where should I write the commands?


yes, in ssh / karaf console

Thanks, I am asking just because it does not work in my case

openhabian@openHABianDevice:~ $ feature:install openhab-transport-coap
-bash: feature:install: command not found

You are running it in your bash console, when you should apply it in the OH console, the one accessible via ssh to localhost: The Console | openHAB

1 Like

thanks, probably my first time using karaf console :slight_smile: after almost 5 years on OH

I also compiled a .kar version which should not need the manual steps for installing the features.
find it here (you can drop it in the addons folder similar to the .jar files)

Alternatively use the jar file and install the features for coap and upnp (see first post)

As said… still version with more debug logging than earlier versions, but hopefully better to keep connection to the devices.

Created separate topic for the new version, so it can be installed directly from openhab.

Hi Marcel,

I am using the AC2889/10 devices and executing settings changes, turning on/off work very well. Thank you very much for taking care of that! Unfortunately status updates still seem to be a problem: The device is always shown as offline and all status data is not transfered to openhab.
Is there anything that I can help to resolve this issue? Did I do something wrong while configuring?

Thank you very much again!


Installed the Binding from the Marketplace, now I’m seeing the Bionding and my Purifier is discoverd.
I can’t get it online thou. In the Binding there is a Field “Key” (Air Purifier device token for communication) that has been filled automatically. Where do I get this Token from? I sometimes see a Token in the coap-communication log. but everytime this Token is different…

Update: The Purifier came online after waiting a little while. does this mean, I don’t need the Token to set it up?

I think the token is needed for the http based devices. I don’t know, I don’t have such a device and it was there from Michaels development.

What I know is that it is not needed for the coap ones.

The ‘alpha’ version works fine, even it stopped with the latest 4.2 snapshot. Do you find time to cancel the verbose log because it spams the log with up to 8 or 10 repeated messages

yes, indeed time to clean it up.
I have myself also not found that it was working less than the earlier version (though it did not solve the connectivity issues as I hoped it would be ;-( )
in the mean time you can prob disable selectively the messages by switching the binding to less verbose messages e.g. log.set WARN org.openhab.binding.philipsair

Hey there. Thanks for the binding.

I tested it with my AC2729/10. It is a 2-in-1 Purifier and Humidifier device, and it seems there are some issues:

  • Humidity data is missing;
  • Displayed Index also does not include Humidity;
  • Filters data seems to be wrong (pre-filter shows 248, carbon and HEPA both 3950);
  • Buttons switch seems to be doing nothing (I hear a sound from the device though);
  • Mode includes not existing values (Bacteria and Night);