Philips Hue: Unable to control devices

  • Platform information:

    • Hardware: VirtualBox VM/32GB HDD/1GB RAM (testing machine while I await my RPI3)
    • OS: Debian 9
    • Java Runtime Environment: OpenJDK 8
    • openHAB version: 2.4.0
  • Issue of the topic:
    Following the “Philips Hue - Bindings” page (https://www.openhab.org/addons/bindings/hue/) I have added my Philips Hue Bridge and bulbs to my ‘demo.things’ and ‘demo.items’ files. After I added the bridge, my three bulbs showed up in my Inbox in PaperUI, but I prefer to manually configure for now. I added my bulbs to my ‘demo.sitemaps’, but neither the toggle On/Off nore the Dimmer slider actually do anything to any of the bulbs.

  • Here is my ‘demo.things’ snippet:

Bridge hue:bridge:1 [ ipAddress=“10.215.1.116” userName=“SECRET” ] {
0100 bulb1 “Master Bedroom (Right)” @ “Master Bedroom” [ lightID=“1” ]
0100 bulb2 “Living Room (Left)” @ “Living Room” [ lightID=“2” ]
0100 bulb3 “Living Room (Right)” @ “Living Room” [ lightID=“3” ]
}

  • Here is my demo.items snippet:

Switch Light1_Toggle “Master Bedroom (Right)” { channel=“hue:0100:bulb1:switch” }
Dimmer Light1_Dimmer “Master Bedroom (Right)” { channel=“hue:0100:bulb1:dimmer” }
Switch Light2_Toggle “Living Room (Left)” { channel=“hue:0100:bulb2:switch” }
Dimmer Light2_Dimmer “Living Room (Left)” { channel=“hue:0100:bulb2:dimmer” }
Switch Light3_Toggle “Living Room (Right)” { channel=“hue:0100:bulb2:switch” }
Dimmer Light3_Dimmer “Living Room (Right)” { channel=“hue:0100:bulb2:dimmer” }

  • Here is my ‘demo.sitemap’ file snippet:

sitemap demo label=“Main Menu”
{

Frame {
Switch item=Light1_Toggle
Slider item=Light1_Dimmer
Switch item=Light2_Toggle
Slider item=Light2_Dimmer
}

}

  • Here is the log file of the pairing of the bridge and discovry of the bulbs:

2019-04-11 20:06:34.694 [INFO ] [ue.internal.handler.HueBridgeHandler] - Creating new user on Hue bridge 10.215.1.116 - please press the pairing button on the bridge.
2019-04-11 20:06:34.751 [INFO ] [ue.internal.handler.HueBridgeHandler] - User ‘SECRET’ has been successfully a dded to Hue bridge.
2019-04-11 20:06:44.855 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘hue:0100:1:1’ to inbox.
2019-04-11 20:06:44.873 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘hue:0100:1:2’ to inbox.
2019-04-11 20:06:44.906 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘hue:0100:1:3’ to inbox.

Any insight or assistance is appreciated! Thanks! :slight_smile:

Check the correct channels, HUE provides color and color_temperature channels, not switch or dimmer channels.
Link switch, dimmer and color itemtypes to color channel, dimmer itemtype to color_temperature channel.

Edit: okay, you have the 0100 type bulb, not sure about that one. My advice was for 0210 type bulb …
Take a look at:

Thanks for the reply Sihui. I have changed my lines to (just showing one of the lines, but I changed the others accordingly):

Switch Light1_Toggle “Master Bedroom (Right)” { channel=“hue:0100:1:bulb1:color” }
Switch Light1_Dimmer “Master Bedroom (Right)” { channel=“hue:0100:1:bulb1:color” }

But same issue.

NOTE: After my first post, I realised that I had forgotten the Bridge ID in my channel entry, but adding it in didn’t resolve the issue either)

OK, so using “brightness” in my channel setting has done the job. I should have understood that chart a bit better :slight_smile:

1 Like