Physically moving a zwave device

Hey guys, I’ve been searching this forum and also Google but haven’t found a good answer, so I’m creating a new thread. Apologies if the answer is basic knowledge.

I have a zwave device that is somewhat mobile in that I move it around and use it in different rooms of my house. (It’s a “lamp module” type device: Aeon Labs DSC06 Smart Switch.) When it was paired with the controller it was within range of the z-stick, and it works just fine if it stays in range. But as soon as I move it to the fringes of my network, which would likely require routing to reach, it doesn’t function. The error I see is “Node is not communicating with controller” in HABmin. It is literally right next to another mains-powered node which works just fine.

I’ve tried:

  • restarting openhab
  • updating to the latest OH2.5 snapshot and zwave binding
  • trying to “heal the device” in HABmin
  • trying to “synchronize network” in HABmin
  • waiting for 2AM nightly heal (multiple)
  • moving the device back in range, confirm it works fine, then moving it back out to the edge

Z-wave is source-routed, right? Any ideas on how to make this node reliable when I move it around, or even in its current location? I have NOT excluded it then re-included as it seems there must be a better way.


I’m real interested in the answer here. For slightly different reasons.

When adding a door sensor recently it wasn’t being recognized when I was in my workshop. There’s three mains powered light switches in there. Came back in the house, it pairs real easy. Move it back into the workshop and nothing in the logs when the door sensor is activated. The LED flashes so it’s detecting the door opening or closing.

OK, I just noticed this in the (DEBUG) log when I requested to Heal the device:

2019-03-06 06:33:38.262 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 12: Configuration update received
2019-03-06 06:33:38.267 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 12: Configuration update set action_heal to true (Boolean)
2019-03-06 06:33:38.270 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 12: Starting heal on node!
2019-03-06 06:33:38.273 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 12: Can not start heal as initialisation is not complete (PING).
2019-03-06 06:34:19.957 [DEBUG] [g.zwave.internal.ZWaveConfigProvider] - No bridgeUID found in getConfigDescription thing:zwave:serial_zstick:7a4110bf

So it seems something is wrong. I’ll move the node back into direct range and try the Heal action again. But what’s up with “No bridgeUID found…”?

Interim update: I moved the device back into range, but “just” into range and also right next to another mains-powered node (that works 100% reliably). It shows as online now, can be controlled, and communicates normally. I’m leaving it there for a new nightly-heal cycles in the hopes that it will discover its neighbour literally inches away, and can use that node for routing afterward. Frustrating that I don’t understand the z-wave source-routing algorithm.

Another update. I did a “soft reset” as was suggested elsewhere by shutting down OH, unplugging the USB stick and putting it back, then restarting OH and waiting overnight. Now my “node 12” (the device I’m trying to move) lists node 15 as a neighbor which was previously blank… but node 15 is way on the other side of the house! It is literally inches away from node 6 (which is a HS-WD100+) and doesn’t see it? I’ll let it heal for another few nights then try moving it further away again, unless anyone else has alternative suggestions.

Hi Jochen

That’s somehow weird from my point of view. I also moved some devices around and didn’t see such a status. However It might take a while until the device recognizes the new route to controller.

What I also wonder is this one:

2019-03-06 06:34:19.957 [DEBUG] [g.zwave.internal.ZWaveConfigProvider] - No bridgeUID found in getConfigDescription thing:zwave:serial_zstick:7a4110bf

I found this as well in my log and don’t really understand the reason for it. As the Stick and the devices are working properly. I don’t think it’s a big issue but it might be misleading. And in my case I noted that the reported ID here differs from what I use to communicate with.


To close the topic, after the “soft reset” (unplug and re-plug the zwave USB stick) and waiting a few days, the network has healed after the node was physically moved. Not sure that’s exactly the right procedure but it worked for me!