Pigpio remote binding wrongly enables all 'registered' gpio-outputs upon disable/enable action

running openhabian (3.1.0) with the pigpio remote binding on a Raspberry Pi 4 Model B Rev 1.2.
running the pigpiod (version 79) on a Raspberry Pi 2 Model B Rev 1.1 connected to a relay-board(16 relays) via the gpio pins.

The following scenario goes wrong:

  • in openhab a total of 12 gpio pins are set as output.

  • the openhab gpio binding has a connection to the pigpiod (deamon) on the pi2.

  • you can nicely switch (activate) a relay and switch it off, using the openhab gui.

  • now we set all gpio pins to ‘off’, the relays are not activated.

  • then pi2, with the relay board is rebooted

  • when pi2 is running again, the openhab gpio binding has lost the connection to the pigpiod

  • using the openhab-gui and doing the enable action on the openhab gpio binding brings back the connection to the pigpiod,

  • but also the 12 relays are also activated, that is not a desired situation.

Why does the binding activate the gpio pins upon re-enabling the connection to the pigpiod (deamon)?

Any idea?

1 Like

I have the same problem. In fact, my external blinds motor fully extended settings got messed up with a recent power outtage. When the Pi booted back up followed by a separate server running Openhab, all the GPIO pins turned on after Openhab reconnected to the pigpio server running on the Pi.

I do not have a solution for this yet. I just wanted to let you know that this problem is not isolated to you. If I come up with something, I‘ll be sure to post it here.