Pine64 Error On Initial Setup

  • Platform information:
    • Hardware:Pine64 A64+ 2GB
    • OS: 1.4.1 Openhabian Image

I have tried multiple times to get this up and running but I get the error where it cannot update the repositories and initial setup exits with the error. My internet is fine, I am using a high quality power source, and multiple SD cards. I believe the issue is with the sources.list, can any devs look into this?

I use this install version

What’s your error? Can you post picture or text?

I may have solution. Want to confirm error though.

I don’t have the exact text but it was something to the effect of trying to update repositories and packages and failing. Then it would say it was exiting initial setup due to failure.

1 Like

That’s what I was looking for. I didn’t want to attach this if problem was related to something else.

Try putting this first boot file on your sd card or rather memory device. Do it after a fresh image. Let me know if it works please. This was an issue in the pi. I am still trying to trouble shoot it, but for now a simple delay seems to fix. This first boot has a delay.

1 Like

It is not clear where in the file I need to add the sleep command.

Add before the apt-get upgrade that is where you add it on the pi version of first boot. There is apt get update then some apt installs.

There was a file attached on github look for sleep 10.

If you dont find it i can look at file tomorrow on my laptop. ALso, you can just try issuing apt-get upgrade on the command line when the install fails. Then reboot. This worked o n my pi once. I just prefer having the file patched so it can be used for future installs.

I edited the file to include the sleep using windows, but now it does not execute on start up. I seem to remember something about having to make sh files executable in linux, and editing via windows seems to have messed this up? It would be helpful if you could include exact steps on how to modify this file.

Also, the install would fail but it would never get to a command prompt, so issuing apt-get upgrade is out.

Press control c when the fail happens. You will get a prompt.

Message me your fist boot file I can edit and return. I don’t use pi not sure if they are the same.

I have found out where to add the sleep, unfortunately the only way I have to replace the file is Windows and this will mess up the permissions and the file will not run.

I will try the ctrl c method and try editing with vim to see if this works.

I added the sleep to the file and it pauses 10 seconds but then fails at the same place it did before.

I ran sudo apt-get update and sudo apt-get upgrade and then rebooted and it worked this time around. Still not sure what’s causing it to fail, but at least it’s working now.

Glad to know you got it.

Yes I am trying to figure out why it is failing also. Issue is when I add logging, it suddenly passed. The sleeps and/or commands on command line are a work around. But they work for now.