Pine64 (v.20170317) Catch22(?) before even starting


Just downloaded the OpenHAB 2 image for a Pine64 (openhabianpine64-xenial-20170317) - for my first try at getting a Linux smart home controller.

Followed the tutorial… BUT it missed that

  1. It skips the WiFi configuration and stucks if you have no Ethernet connected… (I have no ethernet close enough to where I have screen and keyboard to setup the Pine)

  2. If you hammer the keyboard long enough - you can get it unstuck! :slight_smile: Where I tried to run “sudo openhabian-config” to set the WiFi.

  3. However - when running “sudo openhabian-config” - it asks for a password… I used the same that was given (openhabian) - but then I only get told that “command is not found”.

Consider me a clean slate on Linux - so without guidance I am in the dark.

I could not find any more information about this in the starting tutorials or FAQ - so now moving on to you guys.

Anyone knows how I should proceed to get it working with network? Thank you! :smiley:

PS If I had my z-wave USB stick and 433Mhz controller inserted, it also stopped during booting claiming that the modem is not really a modem… or something like that. :wink:


Did you configure wifi prior to the first boot? Check “Wifi Setup” here: openHABian hassle-free openHAB Setup

Yes this is something that needs to be transferred to the main documentation article.

I have tried - but for some reason it does not accept my SSID and pwd - and I have checked more than once or twice that I typed it in correctly. :wink:

Been a while - but soon I will have a window to try and set it up again.

In any case - thank you for your time and effort! Kudos!

There will be a new image in the next couple of days, just so you know :wink:

1 Like