[PioneerAVR] Zone2 and Zone3 ERROR: java.lang.ArrayIndexOutOfBoundsException: -1

@mjptec All my steps:

  1. Build #789 via PaperUI --> above error
  2. new Installation of build # 850 via PaperUI --> above error
  3. uninstall from build #850 via PaperUI and Karaf Console
  4. Copy of Snapshot from stratehm 2016-12-13 to addons folder–> nothing was running
  5. uninstalled it again
  6. Copy of Snapshot from Stratehm 2016-12-22 to addons folder–> nothing was running
  7. uninstalled it again
  8. Installied via PaperUI of build #850 again --> above error

OK. Just in case there is something you didn’t try, these are the steps I took:

  1. Place latest snapshot in addon folder
  2. Uninstall previous binding with Karaf
  3. Add new autodetected thing
    ( pioneeravr:genericAvr:5F9EC1B3-ED59-79BB-4530-745e1c36735d ) -> Nothing working
  4. Restart openhab -> Nothing working
  5. Powercycle AVR -> All working

There might have been other OH restarts as well but that doesn’t matter.

1 Like

Which “latest snapshot” do you mean? 2016-12-22 SNAPSHOT or latest official snapshot? I tried official, no success!

@mjptec I made a complete new installation with Build #858 and copied 2016-12-22 SNAPSHOT into addons folder.
Now it’s running! Thanks a lot!

1 Like

Has anyone configured the 2016-12-22 SNAPSHOT in the things file?

pioneeravr:genericAvr:vsx924 "Pioneer VSX-924" [ ipAddress="", tcpPort=23, useSerial="false" ]

does not work. This is what the discovered thing shows in the jsonDB.
A hint is appreciated. Thanks

Did you also try port 8102?


Please try:
Power on AVR.
Then start openhab.

And be sure that you use correct IP address . There can be another for DLNA or Internetradio…

1 Like

Thanks it works with

pioneeravr:genericAvr:vsx924 "Pioneer VSX-924" [ ipAddress="", tcpPort=8102 ]

Strange however that it gets discovered with port 23 and then works with it, but not when adding the thing manually…

[PioneerAVR] Fix for Zone2 / Zone3

this fix addresses two issues:

  • commands on Zone2 and Zone3 where not working properly due to failing match with GROUP_CHANNEL_ZONE_PATTERN
  • Volume_Level on Zones where not interpreted correctly due to the AVR sending only 2 digits on zone volume rather than 3 digits on Zone1
    Changes where tested on my SC-LX89

this should fix #1206

(as am i new to doing changes to openhab2-addons, Eclipse, Java and even GitHub chances are i got something on the way wrong… please let me know :slight_smile:


Hopefully this will run with my SC-LX72, too.

@mimo74 Do you have a compiled .jar ? So I could test it, too.

not sure i got it completely… but this should include the fix:


1 Like

there is still an issue on setting the volume for zones. I’ll be having a look at that next week.

Ok, thanks!

@mimo74 I installed latest PioneerAVR binding and ZONE2/ZONE3 are detected correctly, now! Thanks a lot! The issue on “setting the volume for zones” does not bother me, because I have set the volume for ZONE2/ZONE3 to a “fixed” value.

See here:

BTW, the issue on “setting the volume for zones” should be fixed with this PR: