Plagued by problems: have to restart for every edit I make

Plagued by problems the last few days.
i suddenly notice that changes in my sitemap and items file are not reflected in the various openhab UI’s.
after trying a lot, i finally remove my itemsfile and sitemap. makes no difference. Still happilly loading in my UI’s, even if I restart them.
The only thing that seemed to help is to do a reboot. I never had that before, If I made an edit it was immediately visible.

Anybody any idea what is going on here?

  • and now ofcourse after a reboot Openhab won’t start
    I have had it… clean install

Sounds a whole lot like a failing SD card.

perhaps. Decent Kingston. Could explain the non consistent results thouhj
Raspi starts but SSH and openhabian not
Got a new one, Samsung, just trying that now.
Fortunately I keep a disc image as back up
Thanks for input, if any, i’d say yes, the card.

I had tried another discimage before and that worked, just put in my own backup on new card and that seems to work fine again. Now only put the latest items and sitemap files on it (and rules and services etc)

The new SD card solved some problems. What it did not solve was having to restart for every edit made in the item, sitemap or rules files.

that appeared to be caused by a ‘fix’ that I was advised to make smart home designer work.
Solution for the dynamic update fail described here