Please add to database Popp Mold detector version 1.1

Tags: #<Tag:0x00007f1877de9a68>

Hello, I have bought a new Popp Mold detector device, and my openhab2 detects it is as an Unknown device. I have found this device in Z-Wave database: https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/990, but it’s present there with version 1.0, and according to the logs, mine is v.1.1:

NODE 69: Unable to find thing type (0154:0004:0014:1.1)

I’m attaching xml file for the node: network_00ce2081__node_69.xml (11.7 KB)

BTW - my binding version is 2.5.0.201901040921

Hi,
Please see information on adding devices to the database here -:

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-database-guide

If you are able to do some of this work yourself it would really be appreciated.

Chris

1 Like

This should get you going:

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/database-history/devicesummary/1164

Please provide the missing parts.

1 Like

Hi, thank you for reference @sihui, I’ve requested edit rights through email to Chris.

And I have a question - in the database guide it’s written that:

If you have a different version of a device in the database, before adding another entry to the database, check that the association group configuration, parameters, and channels are the same. If they are, then it is only needed to update the device IDs of the existing device.

Looks like it’s our case - according to the manual, nothing of listed above has changed compared to the existing v.1.0 database entry. So what’s the need to create and fill in a new entry with id 1164?

If everything is the same we just need to extend the existing entry to your firmware version (remove the upper firmware limit)

1 Like

Sometime new firmware means added or changed features or configuration parameters.

It’s hard to be 100% sure in it, because the device came only with a quick start guide, and manuals on the web don’t state firmware version. But all manuals I’ve seen correspond to the characteristics in the database entry 990. I was going to check popp official website, but it’s down for maintenance.

Check the command classes in your xml against the old entry in the database, especially those which have channels available.
Check all the configuration parameters in the xml from your device against the old device in the database.
Check association groups in your xml from your device against the old device in the database.

If everything looks the same, we can remove the new database entry and add your device to the existing database entry.

1 Like

Checked - everything matches except configuration parameters - this section is just empty in my xml file:

          <entry>
            <commandClass>COMMAND_CLASS_CONFIGURATION</commandClass>
            <COMMAND__CLASS__CONFIGURATION>
              <version>1</version>
              <instances>1</instances>
              <control>false</control>
              <versionSupported>1</versionSupported>
              <configParameters/>
            </COMMAND__CLASS__CONFIGURATION>
          </entry>

But I think this is due to some initialization error - here is what I’ve found in logs regarding configuration command class:

2019-12-03 00:36:00.357 [DEBUG] [alization.ZWaveNodeInitStageAdvancer] - NODE 69: Node advancer - advancing to GET_CONFIGURATION
2019-12-03 00:36:00.358 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 69: Got an event from Z-Wave network: ZWaveInitializationStateEvent
2019-12-03 00:36:00.366 [DEBUG] [alization.ZWaveNodeInitStageAdvancer] - NODE 69: Node advancer: GET_CONFIGURATION - thing is null!
2019-12-03 00:36:00.366 [DEBUG] [alization.ZWaveNodeInitStageAdvancer] - NODE 69: Node advancer - advancing to STATIC_END

Those are read from the database: sorry, I brought you on a wrong track, it should have read “from your manual”, not “from your xml file”

I will update the database this evening.

1 Like

Thank you, I see you have updated the database. Could you please advise me what should I do next in order to make my binding see this update?

Please upgrade to the latest zwave snapshot binding. Merging may take a while, so try it at the beginning of next week.

1 Like