Please help a new user to start with openHab2

Hello there. I’m a new user of this forum and of openHAB.

I’ve a QNAP NAS TS-121 who’ve ARM architecture, and I’ve used openhab 1.7 correctly, but I’ve some problems with yamahareceiver bindings for select net radio, so I’ve tried to use on my pc Eclipse for modify yamahareceiver binding, but I’m not good in this thing.

So I’ve decided to try openHAB 2. I’ve installed on my NAS, but now I can see that all conf folders (items, sitemap, ecc) are all empty. Now I’ve to past the files who’re stored on openHAB 1.8 directory, or I’ve to do something else???

Please help me!


1 Like

Thx sihui. I’ve read your info, but I don’t understand how to choose the default install.
I’ve edited the configuration file, and then i’ve run, but nothing happen, openhab 2 start but no sitemap, no item, nothing, It should auto-fill ??? I’ve installed on Qnap the qpkg of Openhab 2.0.0.a1 (taken on qnap forum) and JRE_ARM 8.65.0. I have to install anything else? Or you tell me where to copy all configuration files manually ??? Thx

I believe you would want to set the package to demo. That should install example configs and sitemaps.


Ah, maybe I’ve make a mistake.

After, when I’ll back home I’ll try to select demo package.
As I understand, i’ve to edit the file ‘conf/services/addons.cfg’ selecting demo and after I’ve to launch
It’s the correct procedure???

So, since I run openhab on a Qnap NAS Arm, the only programs I need are precisely the openhab folder and the JRE version 8 ??? Anything else?


These informations are for people doing a fresh install (i.e. : not coming from OpenHab 1.x), but perhaps they could help you :


Not that I am aware of.



I,m a newbee. I have a qnap 119P II a Arm Nas. I have installed the qpkg of Openhab 2.0.0.b3-1 also the jre environment. When I’m open webinterface i get the message
HTTP ERROR 404,Problem accessing /start/index. Reason: Not Found

The place of the openHAB data


with folders

distribution (demo version)

what I have to do, can you help me?