Popp keypad 700045 : unable to work with it in Openhab despite 'Using Security' is set to true

After many hours trying to include a 700045 Battery driven IP44 keypad for access control, without any success, I request help from the community.

I have tried 2 usb zwave serial controler : a zwave.me (ZMEEUZBB) and an everspring SA413-1.
To make the keypad to be include with the Using Security flag set to true, i setup the USB controler to include “All device” in security mode.
(With standard options, the keypad inclusion is done with ‘Using Security’ flag set to ‘false’.)

I join the last 2000 lines of openhab.log generate with the use of zwave.me usb controler .
The log file contains the exlusion of the keypad (node 8) and the last inclusion holding the node 9.

My issue is that I setup the keypad by sending configuration parameters ou received any event from it.
It seems that the keypad not communicate with openhab (through the serial usb zwave controler) like there is no habilty to communicate using security.

I precise that I succeed to perfectly use the keyboard by using an eedomus box which include the keypad in secure mode.

Can anyone help me to understand what is hapening with Openhab zwave binding ?

Oh ! I forgot to precise the version of zwave binding :roll_eyes:
207 │ Active │ 80 │ │ openHAB Add-ons :: Bundles :: ZWave Binding

Thanks for any help.

openhab-2000lines.log (263.4 KB)

1 Like

Hey Isteelandt,

same problem here, can´t bind with security mode.
I have tried also 2 USB Controller Razberry and an other Zwave Stick.
And i have tried in 2 installations, RPi3 and RPi4, no chance.

Someone there who could help us?

Thanks for help

1 Like

Hi! Same problem here!

I can include the keypad securely and it’s identified by OpenHAB.

However, I can’t set Association Groups using the Paper UI (the settings don’t seem to stick)
There’s no communication picked up by openHAB on the channels, just as I’ve previously experienced with other devices when security isn’t enabled.
Strangely enough, the zwave_secure flag also changes from true to false after the device has been included.
It never seems to wake up since the zwave_lastwakeup or zwave_lastheal never gets set.

OpenHAB doesn’t register any wake ups (doorbell-key) or any manually triggered NIF:s (keys 0*)

It would be very interesting to know if anyone has got this device working with OpenHAB and how.

I’m running on OpenHAB 2.5.2

You mean I can’t (not can). Can you specify wich ZWAVE controler you use ?

I still with no solution but I think it could be important to have this precise far any help from the community.

Yes, I can include it and it’s identified by OpenHAB. Everything appears initially to be working, but when trying to communicate with the KeyPad such as setting association groups or receiving events nothing happens.
This is a behavior I’ve seen with other devices when they have been included non-securely but when security is required.
After a while the zwave_secure flag on the thing is changed to false.

I’m using the Aeotec Z-stick Gen 5 as controller.

Any news?
My search (one year) for alternatives was unsuccessful. :frowning:

I’m running the same - Popp keypad with Aeotec Z-Stick.

I’m on OSX, although shouldn’t make any difference on the platform.

I can include securely, and it has the correct properties, but after an hour or so the zwave_secure flag gets reset back to False.

I’ve done this countless times, but its still refusing to work as its supposed to.

I’ve also setup Domoticz on a Synology box, to see if I can get it working there, and its almost exactly the same - eventually losing its settings in the same way as Openhab does. This uses OpenZwave as the drivers.

Next step is to try on HomeAssistant, as that’s reported to be okay but its also OpenZwave so could be trouble.

I’ve had it working okay on Smartthings, with a driver I wrote (or adapted) myself - so I know its not the keypad that’s at fault.

Reason for all this is trying to move away from Smartthings to a local environment and use of Node-Red…


Solved it!

After initial pairing, you’ve got to bring the pad as close to the controller as you can, and then just keep pressing the Wakeup button (the bell) until it finally completes all the joining bid.

Think I must have pressed it 10 to 20 times, but it finally picked everything up and works fine…

Patience is needed with this one.

1 Like

Great news ! Will try it in the future. Many thanks for your sharing