Popp Wall Plug Switch 05437 - ZW ZS 3500

Hey guys,

I’m just trying to include the Popp Wall Plug Switch. The inclusion works and I can switch it ON/OFF. But I don’t see any values for power consumption and load and I can’t change the configuration of the thing.

09:10:41.575 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 6: Configuration update config_21_1 to 4
09:10:41.577 [ERROR] [ding.zwave.handler.ZWaveThingHandler] - NODE 6: Error getting configurationCommandClass
09:10:41.742 [INFO ] [smarthome.event.ThingUpdatedEvent   ] - Thing 'zwave:device:0b3e5d74:node6' has been updated.
09:10:41.757 [INFO ] [marthome.event.ConfigStatusInfoEvent] - ConfigStatusInfo [configStatusMessages=[]]

What I already did is to include and exclude the thing again and to perform a reset at the Wall Plug.

Many Thanks

The database for this device doesn’t contain any configuration parameters, and also doesn’t have any channels for meter command class. IF this is incorrect, then it would be good if you can add the configuration parameters at least.

Can you post the XML for this device please?


Thanks for your Feedback, but I thought it is the following device:

In the Paper UI it was included as: Z-Wave Node 6: 05438 Indoor/Outdoor Wall Plug Switch

But the on the device the number is 05437. Very strange isn’t it?

I don’t know - I only went on your description of the “wall plug” and 5437 (as per the title of your message) which came up with the device I referenced. The one you now say is 05438?

As requested, can you please supply the XML that is generated from OH so we can be sure what device you actually have.


Here it is:
node6.xml (10.3 KB)

On the Plug itself there is 5437 printed but openHAB says it is 5438 and on the Popp Website it has the number 009006. (http://www.popp.eu/products/actuators/wall-plug-switch/)

Very confusing


From the XML, it looks like everything should be ok. When you say there are no meter readings, do you mean there’s no channel for this, or that there’s a channel, but no data?

I don’t really see any problems from the XML - the configuration is in there, and the association to the lifeline group is set ok (Assuming your controller is node 1).

I’m not sure why you would have the error about not being able to find the configuration class - it’s clearly there.

Some of these zwave.me/Merten devices the last number is the colour or something minor that differentiates the model, so maybe it’s as simple as that…

Hi the channels have been there all the time but no values are transmitted. It always said NULL. Now the values for watts an kWh changed to 0.0. It seems that some magic happened but still no “real” values.

Assuming your controller is node 1

=> Yes, it is.

I just compared my manual with the database entries and I have found some difference.

Command Class Meter has Version 4 in the manual and 3 in the database.
Command Class Association has Version 2 in the manual and 1 in the database.

Could that be my problem? Any idea what I can do because my ideas ran out of stock :frowning:

Very unlikely - the version number in the database is just information - it isn’t used as the binding will do its own thing. In any case the binding probably uses some older versions than the device, but they are backward compatible.

It’s time for a debug log :wink: . View it with the viewer on my website and see what it shows…

OK, I will do so. many thanks for your help!

I just want to add that a restart of OH2 solved the issue. Today I just wanted to test again and it worked. I tried some restarts and so on yesterday which doesn’t have any effect.