Popp Z-Rain not working properly

Tags: #<Tag:0x00007f4349f6b060>

I’ve added a Popp Z-Rain sensor to my OpenHab 3.0 a few weeks ago, but the messages from the device seem to be pretty unreliable. The device does not seem to wake up on its own. Today I checked the last wakeup date in the thing properties and it was almost one month ago. After I removed and re-inserted the batteries the last wakeup date did refresh.

Also the rain alert is only sent sometimes, and sometimes it is set to 99 but then it is not reset to 0 after the rain stops. I don’t know If the device just doesn’t route the packets correctly through other ZWave devices and always tries to send them to the Controller. (The Controller is pretty far away)

I’ve enabled the ZWave debug log and found a lot of these logs:

NODE 64: listening == false, frequentlyListening == false, awake == false
NODE 64: Node not awake!

I will watch the log further to see if there are any messages coming in from the device without removing the batteries. Does someone else also have these problems?

Only unfiltered debug logs are useful for troubleshooting. Yo u can use the zwave log viewer to help and/or post logs here for others to assist.

I’ve enabled the debug log, but there will be quite a lot of logs because I have a lot of ZWave devices. (After startup already 5 MB) Do I have to set the level to TRACE or is DEBUG enough?

The developer has said DEBUG logs are sufficient. The log viewer helps parse the log and, optionally fileter.

Thanks for the hint. I will try and see if I can get something out of the logs. The problem is that I theoretically have to log for 24 hours to see if the device sends a wakeup message or not and I guess the log will be rotating a few times in 24 hours.

@Bruce_Osborne Here is a first Debug Log: SwissTransfer.com - Send large files securely and free of charge

I’ve now simply re-inserted the batteries and after that I triggered the rain sensor manually, but the device seems to have just sent a battery report after re-inserting the batteries. Any idea what is going wrong here?

Many times battery powered devices need to be woken up many times to complete discovery. I may not have a chance to look at the logs until later today.

The device seems to be recognized correctly. I had to wake up the device multiple times until it was recognized correctly. And it is not the problem that it is not working at all, it is just very unreliable. Most of the rain alerts do not seam to reach the controller. To test this I now placed the device inside the house to see if this makes any difference.

Update: I also just noticed that the zwave_neighbours thing property is empty. I guess the device could have problems recognizing it’s neighbours to relay the messages.

Not sure how much that affects things. @chris has much more experience than I do.

Ok, I’m pretty sure now that this must be the problem. If I place the sensor in the house the messages are coming in. The device just does not seem to recognize the other ZWave devices in range to route the message when it is outside in the garden. (It’s just a few meters away, but that seems to make the difference)

Update: Here is the current log: SwissTransfer.com - Send large files securely and free of charge

The device is now in range and I also started a network heal. There are now plenty of messages from the node (Node 64) in the log, but it still has not recognized any neighbour nodes. There should be plenty of mains powered devices near the rain sensor.

@Bruce_Osborne By the way, I just found out that this empty Z-Wave neighbours list is also causing trouble elsewhere. I currently can not use the Z-Wave Network Map because the missing property causes an error in the browsers console when opening the network map and nothing is displayed.

I’ve created an issue in the openhab-webui repository for this: [Main UI] Error in Z-Wave Network Map when zwave_neighbours is undefined · Issue #1037 · openhab/openhab-webui · GitHub

I don’t really know if it is normal that some devices don’t have this property or if this is an error of the ZWave device itself or an error in OpenHab. Maybe @chris can explain this?

Update: I found out that the Z-Wave Network Map only has problems with Z-Wave devices where the property is missing completely. This is not the case with the Popp Z-Rain. There the property is set to an empty string. But the property was missing on one devices where the Z-Wave device type was not discovered after adding it to the network, and I was also not able to remove the device from the controller after this. So I just left the device as an invalid thing in the config so it does not appear anymore in the inbox. This results in a Z-Wave thing without the zwave_neighbours property and this breaks the Network Viewer. I just updated the GitHub issue.

I know there are various UI issues related to zwave, There appears to have been little coordination with the zwave developer when the ui was developed. Kost od us find the network map of little use since it just attempts to graphically shoe the neighbours which may have mo relation to the network routing, In fact in my 3.x testing I have not even opened the network map.

Yes I’ve also noticed some strange behaviours in the main ui on ZWave things.

I’ve also contacted the support from the shop where I ordered the rain sensor. They suggested that I should try to remove the device and add it again outside the house using the network wide inclusion feature. (Which I’ve enabled on the controller) I just tried that, but the device was not found by the ZWave scan outside the house. Only if I pair the device inside the house it get’s detected.

I’ve never tried to add a device outside the range of the ZWave controller. Maybe the problem is that the device tries to relay the message using a specific other ZWave device every time and that this device does not relay the message to the controller for some reason?

I also checked the ZWave debug log after the failed inclusion from outside the house, but I did not find any messages from the rain sensor. Any ideas how I could analyze this further?

Personally I was a little disappointed at time with Z-Wave Plus range.

I think there is supposed to be (a mode?) in the 700 Series Z-Wave Plus 2 standard permitting a longer range. The binding currently works with the newer devices because they are backward compatible but does not work with the newer controllers.

Sure - if the information has not been downloaded from the device, then the property will not be set - this is normal. Normally the neighbours will be updated once per day, but if the device is a battery device, sometimes this might not happen every day.

That is true, but it is a very different system and is not a mesh network. I’m not sure if there are any of the long range devices available yet.

Thanks for the info, but the device was up for weeks and the property is still empty. Should’t it be loaded at some time? (I also have some other devices where this property is empty and the are online for months)

Also why does the device just not work outside the range of the controller? Is this a problem of the rainsensor itself? Should I contact the manufacturer regarding this problem?

The device has no way to communicate outside the rang of the controller much like you cannot use your home Wi-Fi network while driving your car on the freeway. You are out of its range. Your wireless phone only works when on the provider’s range so they have coverage maps.

Yes, but ZWave is a mesh network. Every mains powered device does extend the range of the network and routes the traffic of devices outside the range or the main controller. (Just like with ZigBee) I also have another wind weather sensor in the garden and this device works just fine outside the range of the controller because it routes the traffic over other devices near it.

If the device has been designed to route, yes that is the case.I guess I misunderstood your question.

In my experience some mains devices route better than others.I too have been disappointed with the routing capabilities of some devices.

Yes, but as I said my Popp Z-Weather station is working fine and this device is even further away from the controller as the rainsensor. So I guess this must be a problem of the rainsensor itself.