Possible file permissions issues

I upgraded my openhab install to 1.8 but now some of my transforms are not working.

I’m guessing this is a permission issue but I’m a bit of a noob on linux so not really sure what I should do about it.

I did chown some of the files to get the configuration files shared via samba - so it could be that after upgrading this has caused issues?

These are the permissions if that helps!

Is the openHAB server not running under the openhab user account?

No, I believe it’s running as my user… but I honestly don’t know how to tell!

Ok, looks like it is running as openhab!

I’m willing to bet money that you are missing a closing something (quote, paren, etc). It is looking for a file named

/etc/openhab/configurations/transform/bbsb_a2.map)], >[OFF:

which obviously doesn’t exist as a file. Check your binding again and make sure it is in the right format and all opening things have closing things.

Here is the item, I don’t think there is anything in there wrong :-s

Switch Switch_LoungeLight “Lounge Light” (Lounge,Lights,bbsb) { udp=">[ON:], >[OFF:]" }

No errors in the designer either

I swear this was all working before upgrading. I took an image of the vm this is running on so I could roll back if it would help (it would be a pita, but could be done!)

In the examples on the wiki it has the transform part in single quotes. From the wiki page:

tcp=">[ON:'MAP(my.device.map)')], >[OFF:'MAP(my.device.map)']"

NOTE: It looks like there is an errant closing paren in that first example for the ON clause.

It’s still not working - I’m getting this error now.

Caused by: java.io.FileNotFoundException: /etc/openhab/configurations/transform/bbsb_a2.map)’], >[OFF:'MAP(bbsb_a2.map (No such file or directory)

Do you think it’s actually looking for a file called ‘/etc/openhab/configurations/transform/bbsb_a2.map)’], >[OFF:‘MAP(bbsb_a2.map’?!

Yes. That is why I think something is wrong with your binding def. I don’t use this binding so all I have to go on is the wiki and the error though.

Yes, that’s what it’s trying to do. There has to be some error in your .items file. :confused:

my binding changed from 1.7 to 1.8, my items haven’t changed. I’m convinced it’s an issue with the binding.

I have noticed the regex to pattern match the mappings got updated in November with this: https://github.com/openhab/openhab/commit/0c2a234a161b64a75b0c012bdc90750b316949f0#diff-7a36b1ec45b626f7e08698a655a97547

I don’t really understand how thats used so I can’t be 100%, buy my spidey sense is going off!

I’m going to try and roll back that addon to the 1.7 version.

@steve1, could you have a look at this?

Switching back to 1.7 binding fixes it.

So it’s possible my items config is wrong, and needs changing to a different format, but it did used to work!

It would be a regression in the binding to break existing binding strings in 1.8 from how they worked previously.

Yes, this is a regression. The modified regex matches space-separated binding config elements and it should match comma-separated elements. I’ve submitted a bug fix (PR #3792).

1 Like

I take it there is no harm with me just sticking with the 1.7 version of the binding for now then?