postUpdate Not Updating - SOLVED

I keep trying and reading and reading and trying and still not getting postUpdate to work for resetting a number. This is what I have…

rule "Today Plant Watering Reset"
    Time cron "50 59 23 * * ?"
    Plant_DailyWater.postUpdate (0)
	Plant_DailyWater1.postUpdate (0)
	logInfo("plant water counter", "water counter set to zero")


var Number Plant_DailyWater //used in the rule as a counter
Plant_DailyWater1.postUpdate(Plant_DailyWater) //used to post in sitemap


[ERROR] [ntime.internal.engine.ExecuteRuleJob] - Error during the execution of rule 'Today Plant Watering Reset': 'postUpdate' is not a member of 'null'; line 43, column 5, length 31

sure it’s something simple but have not been able to work it out.


One of those variables is null. Comment out one at a time until you know which.

postUpdate is for items and I see that Plant_DailyWater is a variable.
So, this should be used:

Plant_DailyWater = 0

Perfect! The Plant_DailyWater = 0 fixed it!

Thanks guys!

Marked solved!