Problem accessing /start/index


in unzipped the latest an ran on my raspberry pi, and when a try to connect to pi:8080 i just get “Problem accessing /start/index” what am i missing?


Lolz im doing the same thing right now, getting the same error whatever i do, both by apt install and manual install ! on Raspberry Pi 1!

Did you wait long enough? On a RasPi 1 it can take up to 3 minutes until the webserver with the UIs is up and running. Have a look at the log files if the system is still busy or has completed the startup.


I am facing the same issue. Installed on my Raspberry PI 1 B+.
Waited for 5 mins still getting the same error.

Problem accessing /start/index. Reason:

Not Found

Powered by Jetty://

After rebooting my Raspberry PI 1 B+ I got it working.
The solution is to wait for 3-5 mins as mentioned by @Kai.

I’m having the same issue but rebooting and waiting 3-5 mins is not working for me. Any other suggestions? I’m on the Raspberry Pi 3 B.

Enable debugging (“set:log DEBUG”) and check log files?

Thanks for your quick reply. Here is a snippet of what it’s outputting when I do log:set DEBUG:

2016-06-20 07:46:45.690 [DEBUG] [org.eclipse.jetty.server.Server     ] - REQUEST GET /start/index on HttpChannelOverHttp@1653582{r=1,c=false,a=DISPATCHED,uri=/start/index}
2016-06-20 07:46:45.692 [DEBUG] [ax.web.service.spi.model.ServerModel] - Matching [/start/index]...
2016-06-20 07:46:45.693 [DEBUG] [ax.web.service.spi.model.ServerModel] - Path [/start/index] does not match any context
2016-06-20 07:46:45.695 [DEBUG] [.jetty.server.handler.ContextHandler] - scope null||/start/index @ o.e.j.s.h.ContextHandler@137a923{/static,null,AVAILABLE}
2016-06-20 07:46:45.696 [DEBUG] [.jetty.server.handler.ContextHandler] - scope null||/start/index @ HttpServiceContext{httpContext=DefaultHttpContext [bundle=com.eclipsesource.jaxrs.publisher_5.3.1.201602281253 [11], contextID=default]}
2016-06-20 07:46:45.699 [DEBUG] [.jetty.server.handler.ContextHandler] - context=||/start/index @ HttpServiceContext{httpContext=DefaultHttpContext [bundle=com.eclipsesource.jaxrs.publisher_5.3.1.201602281253 [11], contextID=default]}
2016-06-20 07:46:45.706 [DEBUG] [org.eclipse.jetty.server.session    ] - sessionManager=org.ops4j.pax.web.service.jetty.internal.LateInvalidatingHashSessionManager@1107983
2016-06-20 07:46:45.707 [DEBUG] [org.eclipse.jetty.server.session    ] - session=null
2016-06-20 07:46:45.709 [DEBUG] [eclipse.jetty.servlet.ServletHandler] - servlet |/start/index|null -> org.eclipse.jetty.servlet.ServletHandler$Default404Servlet-468f40@6e060e40==org.eclipse.jetty.servlet.ServletHandler$Default404Servlet,-1,false
2016-06-20 07:46:45.710 [DEBUG] [ce.jetty.internal.HttpServiceContext] - Handling request for [/start/index] using http context [DefaultHttpContext [bundle=com.eclipsesource.jaxrs.publisher_5.3.1.201602281253 [11], contextID=default]]
2016-06-20 07:46:45.728 [DEBUG] [y.internal.HttpServiceServletHandler] - handling request org.ops4j.pax.web.service.jetty.internal.HttpServiceRequestWrapper@117eb97, org.ops4j.pax.web.service.jetty.internal.HttpServiceResponseWrapper@1d2856d
2016-06-20 07:46:45.729 [DEBUG] [eclipse.jetty.servlet.ServletHandler] - chain=null

You can see the full output here:

Not really sure to make of it. Do you see anything out of the ordinary here? Thanks so much.

I just had the same issue on Raspbian install. RPI3.

When I run as normal user I get the same “page not found”. Error log shows:

2016-07-27 21:54:49.071 [ERROR] [.glassfish.hk2.osgi-resource-locator] - FrameworkEvent ERROR - org.glassfish.hk2.osgi-resource-locator
org.osgi.framework.BundleException: Exception in org.apache.karaf.features.internal.service.FeaturesServiceImpl$3.end()
        at org.eclipse.osgi.internal.framework.OSGiFrameworkHooks$CoreResolverHookFactory.handleHookException([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.internal.framework.OSGiFrameworkHooks$CoreResolverHookFactory$CoreResolverHook.end([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleResolver$ResolveProcess.resolve([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleResolver.resolveDelta([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer.resolveAndApply([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer.resolve([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer.resolve([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.Module.start([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.framework.eventmgr.EventManager$[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
2016-07-27 21:57:08.093 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-package-standard': Error restarting bundles
2016-07-27 21:57:08.557 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-package-standard': Error restarting bundles
2016-07-27 21:57:09.483 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-package-standard': Error restarting bundles

As I see something fails while trying to install I guess it’s a permission issue. So after this I started with sudo and the problem was resolved.

Hope it helps

… Today I tested Openhab2 with the actual build. Unfortunately, I have the described problem.

Does anybody has a solution / reason for that?


Make sure that you wait a bit and then refresh the page… it takes sometime for the java stuff to load.
If no luck = enable debug (see above) and check the /userdata/logs/openhab.log in the openhab installation directory.

I just installed OH 2.0.0.b4 (Build #477) on RPI3 and all works fine. I created a new user (openhab) and gave ownership to all installation directories. I used also the systemctl method to install the service (see:

Ps: Great stuff guys! Love the openHAB 2!

Thanks für your reply. It Seems you are right. It takes a while…


1 Like

I have the same error. Waited 15 minutes, still this error.