Problem adding Z-Wave battery devices by discovery - how to add via .Things


I’m using OH 3.2.0 and, after a weeks, I’ve not been able to add any battery Z-Wave device via the UI. So, I’m either doing something wrong or I need to use the .Thing file approach. I seek advice.

When the system discovers the battery devices they just show up as generic without channels. I understand this means they are not “initialised”. Both appear in the list of supported devices.

Also, if I do a second scan the same devices are found but for the next node numbers. Odd :slight_smile:


  • OH 3.2.0 (new install, not migrating)
  • Z-Wave devices:
    • Aeotec Z-Stick Gen5+
    • Aeotec Door/Window Sensor 7 ZWA008-B (with firmware update)
    • Dome (Elexa) Door and Window sensor DMWD1
    • Aeotec Range Extender 6

The range extender is discovered just fine and shows as a range extender. I’ve removed it from the network while I’ve been trying to get the 2 battery devices working.

What I have tried:

  • Twice: Deleted things, deleted xml files OpenHAB\userdata\zwave, factory reset all devices and controller and re-add and rediscovery by scan.
  • On both Dome and Aeotec sensor many many wakeups. Left running for days.
  • Controller reset, the many more sensor wakeups and left running for days again.

What have I missed? It does seem to me that the discovery just does not work.

So … I turn to the .Things file settings. Can somebody point me to were I will find specific into on setting up these devices in the XML file? - seems I need to know magic numbers :slight_smile:

Thanks in advance.

Now after a couple of hours after posting the above and 2 weeks trying … bingo, part solved. I found Silicon Labs Simplicity Studio 5, Z Wave PC Controller and it allowed me to get info from the sensor (on first wake up!). OH3 now shows the device correctly.

Fix was:

  1. Shutdown OH3
  2. Start Simplicity Studio
  3. Select Tools | Z-Wave PC Controller
  4. Z-Wave PC Controller opens (use setup to select the COM port)
  5. Select “Network Management”
  6. Controller and sensor(s) are listed.
  7. Select the sensor node
  8. Option button appear on the right
  9. Select “Node Info” - a command is placed in the queue.
  10. Wake up the sensor - after about a minutes the command classes show all commands expected.

After that shut down Z-Wave PC Controller, restart OH3, in the UI select the controller and select “Synchronize Network”. Done.

Conclusion: OH3 Z Wave binding does not get device info. So initialization does not complete.


While it may take a long time for initialization to complete, I’ve never seen a case where it wouldn’t complete (unless of course the device is not in the zwave database). And I’ve included many dozens of battery powered devices, a number of which are Aeotec and Dome devices.

From my perspective, the issue is that it can take many, many wake-ups for initialization to complete. It’s especially severe when the device has a lot of command classes and config parameters. In some cases it’s required 20+ manual wake-ups. If the device is left to wake up on it’s own, and depending on what the wake-up interval is, I easily could see some devices taking a week or more to fully initialize. :sob: :flushed:

There’s some discussion of the issue here.

1 Like

Ditto on @mhilbush comments. More recently I put together a PR for One and Done battery device initialization here. Lengthy, but explains the issues you faced.


That is a very interesting PR and I’m a little disappointed that it has not created a little more discussion on github. It seems very well researched and tested. I am wondering if the original author of the zwave binding has abandon the binding as I was told by another (formally very frequent poster in this forum) that he and the original author of the binding were working on an alternative solution. (an openHAB replacement)

1 Like

Thanks guys, I get it. Plenty of threads saying it can takes weeks. Thing is … how can that be acceptable? Saying it will work after weeks does confirms a fault. That is not “working”.

When I do this will the Z-wave PC Controller it gets it all in one wake-up (first time).



no no
you don’t have to wait weeks
just keep waking the device by pushing wake button (see the documentation for your device) It sometimes takes a bunch of tries but eventually it works
Sorry… the discussion kind of took a left turn

While @apella12 has proved there is an issue and created a PR like @Andrew_Row I have never seen the issue because I do not let devices go to sleep either.

If you have a zniffer you can watch for the no more info and wake the device so include is a lot faster and reliable.

Also some devices can be set so they do not go to sleep for many minutes which also avoids the issue.

There have been several threads on this with solutions in the last few months like this one so the discussions are here but hard to find. ZWave inclusion fails for Aeotec SWA003 - #10 by apella12

No - not at all. But sometimes “life” gets in the way of spending all my time on openHAB and I have to do other things as well. sadly the past couple of months have been pretty busy through the summer months.

I’m not exactly sure what you refer to here, but we do use a fork of openHAB for commercial users. This was needed to add features that were not supported by the maintainers so had to be on a separate fork. This doesn’t impact the bindings though - it’s a core fork.