Problem after restart QNAP


i make my first experiences with openHab.

i installed “openHAB_2.0.0-b5-0_offline.qpkg” and JAVA (JRE_ARM V8.65.0) on my QNAP TS-419p (QTS 4.2, Version 4.2.2).

The installation worked fine, i chose standard-installation and after a few moments i could open the paper ui at port 8090.

But after a restart of the qnap, the openhab-server isn’t started, though the APP-Center of the qnap told me so.
The openhab paper ui isn’t available at port 8090.

The qnap-log told me “Java not found! Please read the documentation about details.” I could not find any details.

The openhab.log looks like this:

2017-01-22 16:52:21.483 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at /start
2017-01-22 16:52:22.186 [WARN ] [] - Exception caught while starting SSH server Address already in use
at Method)[:1.8.0_65]
at org.apache.sshd.SshServer.start([59:org.apache.sshd.core:0.14.0]
at java.util.concurrent.Executors$[:1.8.0_65]
at java.util.concurrent.ThreadPoolExecutor.runWorker([:1.8.0_65]
at java.util.concurrent.ThreadPoolExecutor$[:1.8.0_65]
2017-01-22 16:56:14.132 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
2017-01-22 16:56:15.164 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /ui
2017-01-22 16:56:17.038 [INFO ] [basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app

I tried “./ stop” and “./ start” at “/etc/init.d” and get the answer “JAVA_HOME is: /usr/local/jre”. But i can’t solve the problem.

The only solution i could find is to remove openhab from qnap and install new. Then i start at the beginning.

What can i do to solve my restart-problem?

1 Like

I have the same problem, I connected a rfxcom transciever to the QNAP. Starting Paper UI , add the RFXCom binding and manually add via a .things file with a klikaanklikuit switch. The rfxcom and the switch were online. After a while I restarted the openhab2 app and the devices where offline. After a new restart a lose contact with Paper UI.

I saw a ups_yec process and a java process on the usb port. (lsof /dev/ttyUSB0)

After this problems a configurate Openhab2 on a pi 3 and I’m using the rfxcom transciever and it worked well and also after a view restart’s. The Paper UI is still in the air.

Maybe there is a conflict with java and other program, for me to difficult to solve this problem

Perhaps I should do that, too.


I have the same problem like Andre. I have more then one installed the openHAB_2.0.0-0 with qpkg new. After the new installtion i can work. If i boot the qnap ts-469l, then is openHAB not working.


Same problem for me. Worked ok, and after reboot I got the “Java not found” message und OpenHAB is not reachable on 8090. Any news?

I have the same problem on my Ts-251 and no solution so far :frowning: anybody?

I’ve installed openhab sucessful on my TS469 pro. After ~ 2 weeks it crashed and I got the message: Port 8090 or 8444 already in use and secounds later: Java not found! Please read the documentation about details. I tried everthing to bring it up again. - stop start qpkg - stopped openhab restarted java - rebooted the nas At the end I did a full new instalation and it worked again for 2 days then it crashed again with Java not found!..
I didn’t found something relevant in the logs.
Ideas to mitigate the issue?

I have the same problem on TS-453A: “Java not found! Please read the documentation about details”

in the openhab.log I found: “2017-02-16 02:48:42.649 [WARN ] [o.openhabcloud.internal.CloudService] - You are running Java 1.8.0_65 - the openhab Cloud connection requires at least Java 1.8.0_101, if your cloud server uses Let’s Encrypt certificates!”

On the AppCenter I installed JRE 8.65.0 (last available).
Could be that I enabled the CloudService and it is not compatible with jre 8.65?

After observing this for a while, it seems that in fact it’s working for me. After restarts of the QNAP also openHAB is started reliably. And manually stopping and starting the “app” works as well. However, it seems that you should wait ~2 minutes after stopping before starting again because the shutdown of the app is not yet completed when the user interfaces pretends to have stopped it.

Any News on this theme?
Got the same problems here on my TS-219P II.

I think “use a Pi3” issn’t the right solution… or is it?

I have the same problem with OH2 on TS-419P.
To my understanding it is related to the fact (assumption) that OH2 starts while JRE is not yet (fully) started and therefore the JAVA_HOME is not yet set.
I guess the start of OH2 has to be delayed until JRE is fully started.

1 Like