Hi all,
I upgraded my system from 2.2 to 2.5.
The docu tells me, that config parameter are missing.
In a other post I saw the recommendation to delete and add the things again.
Is this correct to delete/add them via the PaperUI or what else do I should do?

This question might be dump, sorry for that. I’m new to OH.

Yes, that is correct. It is often a good idea (particularly after a big jump in versions like that) to remove your things and re-add them to OH. DO NOT remove/exclude the devices from your z-wave network, that’s unaffected, but the thing definitions in OH do need to be upgraded and this can only happen if you delete the things and re-add them.

1 Like

Yes, Justin is correct, going from 2.2 to 2.5 you will definitely need to delete and re-add your things.

It worked for my Things.
But now my z-wave Things and the controller (Aeotec z-wave stick gen5) are going offline after a couple of minutes and reconnect again. I can also follow this behavior in the attached log file.
With OH 2.2 my system was very stable.

Any ideas?

events.log (32.2 KB)

yes, this is a problem that cropped up at the time when I think 2.5.0 released. First, the rest API moved. The configuration is in .cfg file or somewhere. Hang on and I’ll try to find the threads involved. There isn’t anything wrong with your zwave, OpenHAB can’t find a certain addon and is trying to reload the misconfigured addon over and over resulting in your issue. I will try to find the threads describing the fix so check back in a few minutes or search restarting every 60 seconds

check this thread

Here is a quote from Bruce that describes the problem:

If you are running openHAB 2.5 or newer and upgraded, you likely have an invalid addon in your config that restarts all addons every 6- seconds trying to load the invalid one. A common culprit is restdocs since its location moved. Check the addons.config (not addons,cfg) file down in the userdata tree.

This is the content of my addons.config file.
What should I change?


I cannot find any add-on which is a candidate for the issue.

Have you tried removing all the addons and then adding them back in one by one testing each time in between?

1 Like

Do you mean I should remove and re-install all the bindings? Other addons I don’t have configured.

That is one tactic many people use to troubleshoot similar problems. Uninstall all your currently installed bindings (this won’t impact your things or items, they will just report as uninitialized until the relevant binding is reinstalled). Then reinstall a single binding. When you are satisfied that binding is not the issue, then reinstall the next one. At some point you will likely isolate the problem.

Although rossko57 is probably correct and the dead yahooweather binding is the most likely culprit.

thanks, removing all bindings and add them again solved my problem. The latest stable OH version is now working !

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.