Problem Configuring Amazon Alexa Binding

Hi All
I’m new to OpenHAB and have just got it loaded and partially configured for the first time. I have a Loxone System which I currently control via Alexa using 1Home or Voxior. I want to change that to OpenHAB.

OpenHAB is running on an RPI 3b and I’m using Windows10 machines with Chrome Browser.

I have the Loxone Binding installed and can see all of my ‘Devices’ and have installed the AmazonEchoControl add-on. When I go to 'openhabiandevice:8080/amazonechocontrol to link it to my Amazon account, I type in my Username and Password. Amazon sends a text to my phone so I must ‘Allow’ the login, but the OpenHAB login to Amazon page has refreshed and lost my details before I can ‘Allow’ access. So I’m stuck in a loop.

If I go to and login directly, I get straight in, so it seems to be a problem with;

  1. Authentication
  2. Login Screen Timeout

Can anyone help me please?

same here

Did you enable 2FA / 2 step verification on your amazon account ?

I have the same issue. I do not have 2FA turned on.

Does anyone know of a fix for this?

I should add that when I log in to via a seperate web browser I can see the connection to Openhab (Smart Home/Smart Home Skills/Openhab) and can go into Settings and it shows the Account Linking as ‘Linked’. Nevertheless the Openhab Paper UI is showing Alexa Thing as ‘Offline - Pending Configuration’. I have not done any further testing to see what else is working or not working at this stage.

Thanks Wolfgang_S. I’ve set that up ready for when I next try loading the binding in a few days time.

It looks promising!

@Wolfgang_S Setting my browser so that it didn’t require verification worked a treat, so simple when you know how!

Thanks again